Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Closed Thread
Thread Tools Display Modes
Old 01-23-2006, 04:45 PM   #1
Flagship's Avatar
Join Date: May 2005
Location: Some insignifcant planet.
Posts: 8,049
Default Creative Labs X-Fi

It appears that some people are having problems with the X-Fi cards.

I have gained access to one and will be attempting to duplicate the problems and hopefully figure out what the problem is.

If you are having problems with X-Fi card please post your hardware configurations and what problems you are having. Please do not turn this thread into a discussion. Keep it to the facts only so that I can review it quickly.

I need this info.

Mother board.
Video card.
Other plugin cards.
Operating System.

Does the problem only occur while playing a game. If not, what were you doing when it occured. If so, what game.


Note: If you do not have a X-Fi card your post will be deleted.
Flagship Industries, Inc.
Flagship is offline  
Old 01-23-2006, 08:03 PM   #2
Junior Member
Join Date: Jan 2006
Posts: 2

I have a 2.8ghz pentium D processor, 1 gig of ram, a Creative SB X-Fi and a Radeon X600. I am running under Windows Media Center 2005. Whenever I try to test my microphone in ventrilo it won't work and other people can't hear me. I have tried multiple microphones and none of them work. I am not in any game while I am testing this and the microphones work in the windows test record in control panel. Hope that helps.
CPUProgrammer is offline  
Old 01-23-2006, 11:13 PM   #3
Junior Member
Join Date: Jan 2006
Posts: 10

DFI Lanparty UT SLI-DR Expert (nForce4)
2x1024 OCZ EB Platinum Ed. PC4000
2x nVidia 7800GT by eVGA in SLI mode
X-Fi Fatal1ty Soundcard and I/O module PCI
A 4-port USB 2.0 PCI card
Windows XPSP2

I lose outbound communications when I connect to a BF2 server, as I described in my recent thread:

But I'm not sure whether my symptoms are the ones that you're trying to address here.

ozrico is offline  
Old 01-24-2006, 05:46 PM   #4
Junior Member
Join Date: Jan 2006
Posts: 10

The X-FI gaming control center option changes my mic settings until I am unable to input in vent. This problem occurs everytime I run Battlefield2

Asus Nforce mobo
AMD 3800
2 gigs RAM
CyberKiL is offline  
Old 01-24-2006, 07:54 PM   #5
Junior Member
Join Date: Jan 2006
Posts: 2

Motherboard: eh, i dunno
Creative X-FI
Intel Pentium D 3.0 GHZ
2 gigs RAM
NVidia 7800 GTX
I would love it if you would fix this, i got booted from my WoW guild yesterday cause i couldnt speak in Ventrilo

Edit: it occurs in and out of the WoW
evilbendy is offline  
Old 01-25-2006, 04:46 PM   #6
Junior Member
Join Date: Jan 2006
Posts: 10

I have fixed this problem!! I'm guessing this will work for all of you as well who cannot speak while in games, or even in gaming mode. The X-FI automaticly switches to game mode when a game is launched and this must cause the volume of your mic to get way too low. You can fix this in the Vent setup. Find the line volume in setup and move the tab to the right closer to Max until you can input correctly. Use Test to see if that works.

Good Luck
CyberKiL is offline  
Old 01-25-2006, 09:01 PM   #7
Junior Member
Join Date: Jan 2006
Posts: 5

Athlon XP2500+
Asus A7N8X-E Deluxe Motherboard
Tekram DC390F SCSI 2 Card
PCI - Cardbus Adaptor
2GB PC3200 Ram
Sound Blaster X-Fi Professional
Geforce 6600GT 128
Windows XP Professional SP2 All Current Updates
Battlefield 2 V1.03

When I run Ventrillo all by itself, it run's beautifully, I chat, people can hear me, I hear them, however, if I run BF2 I get the infamous

Sound Input Device Has Been Closed
It Was Sending data faster than it should be

Try enabling the 'Use DirectSound for input device' option.

error. which does not occur when the test or monitor button is pushed.

I am running the most updated drivers for my sound card, I have tried running BF2 First, and then starting Ventrillo, I am running BF2 in hardware mode without the X-Fi special setting. I've tried it all three ways.

Last edited by The_Revrend; 01-26-2006 at 04:47 PM.
The_Revrend is offline  
Old 01-25-2006, 09:37 PM   #8
Junior Member
Join Date: Jan 2006
Posts: 10

What I posted above is not actually working all the time. For some reason the X-FI is messing with BF2 audio and possibly vent settings. First of all Disable BF2 VOIP, and move the tickets that say 100% down to 0%. That fixes vent most of the time. I think it might be a volume issue that's the cause for BF2, X-FI and Vent issues. I can yell in my mic but vent will barely hear me.
CyberKiL is offline  
Old 01-26-2006, 11:59 AM   #9
Junior Member
Join Date: Jan 2006
Posts: 1

P4 3.4
Abit IC7 Mobo
1Gb Memory
X-Fi Fatal1ty
BFG Nvidia 6800 Ultra
Windows XP Pro

Mic does not work when trying to play WOW, I do not have BF2 installed. I am using the gaming mode. I will try to switch to one of the other modes when I get home to test.


EDIT (2/8/06) - Ack, I am such a noob. On the X-Fi, the front panel mic input is "Mic 2". I had to enable the input in the mixer properties and select "Mic 2" for the recording channel. I assume this is probably an issue that others are having.

Last edited by PerfectFusion; 02-08-2006 at 04:48 PM.
PerfectFusion is offline  
Old 01-26-2006, 05:08 PM   #10
Junior Member
Join Date: Jan 2006
Posts: 2

I've found a few things that help

*If you can plug the microphone in in the front and the back, plugg it in in the back

*change macroFX to on, that helped a little for me

*Also change the line volume to the maximum amount
evilbendy is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -5. The time now is 05:31 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.