Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 07-13-2009, 09:25 PM   #1
Kirisi
Junior Member
 
Join Date: Jul 2009
Posts: 2
Angry Help Needed

HI,

I have searched through the other post and still I am unable to fix my problem

Im getting - Failed to create directory 'C:\users\?\Appdata\Roaming\Ventrilo'. Program aborting

I have tried using the guide fixing the registry and that hasnt helped.

Im have a vista home premium service pack 1.

Any help would be greatly appreciated

Thanks
Kirisi is offline   Reply With Quote
Old 07-14-2009, 03:28 PM   #2
mjgraf
Senior Member
 
mjgraf's Avatar
 
Join Date: May 2005
Location: Some say in my own little world
Posts: 15,502
Default

is there an error number reported with this message?
this may be an issue with the registry and the error number will allow us to check the exact error.
mjgraf is offline   Reply With Quote
Old 07-14-2009, 03:43 PM   #3
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,459
Default

the problem is the "?" is an invalid pathname and is probably set in the registry.

check your registry entries to these:

[FONT=Verdana](Windows Vista)[/FONT]
[FONT=Verdana]Start / Run[/FONT]
[FONT=Verdana]Regedit[/FONT]

[FONT=Verdana]For per-user special folders, navigate to the following location: [/FONT]
[FONT=Verdana]HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer \ User Shell Folders[/FONT]

[FONT=Verdana]Double-click the corresponding shell folder name [/FONT]

[FONT=Verdana]Change the Value data accordingly, mentioning the destination path [/FONT]

[FONT=Verdana]Close Regedit.exe [/FONT]

[FONT=Verdana]Default shell folder paths – Listing[/FONT]

[FONT=Verdana]Per-User special folders[/FONT]

[FONT=Verdana]Value name (Special folder)[/FONT]
[FONT=Verdana]Value data[/FONT]

[FONT=Verdana]{374DE290-123F-4565-9164-39C4925E467B}[/FONT]
[FONT=Verdana]%USERPROFILE%\Downloads[/FONT]

[FONT=Verdana]AppData[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming[/FONT]

[FONT=Verdana]Cache[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Local\Microsoft\Windows\Temp orary Internet Files[/FONT]

[FONT=Verdana]Cookies[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Co okies[/FONT]

[FONT=Verdana]Desktop[/FONT]
[FONT=Verdana]%USERPROFILE%\Desktop[/FONT]

[FONT=Verdana]Favorites[/FONT]
[FONT=Verdana]%USERPROFILE%\Favorites[/FONT]

[FONT=Verdana]History[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Local\Microsoft\Windows\Hist ory[/FONT]

[FONT=Verdana]Local AppData[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Local[/FONT]

[FONT=Verdana]My Music[/FONT]
[FONT=Verdana]%USERPROFILE%\Music[/FONT]

[FONT=Verdana]My Pictures[/FONT]
[FONT=Verdana]%USERPROFILE%\Pictures[/FONT]

[FONT=Verdana]My Video[/FONT]
[FONT=Verdana]%USERPROFILE%\Videos[/FONT]

[FONT=Verdana]Nethood[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Ne twork Shortcuts[/FONT]

[FONT=Verdana]Personal[/FONT]
[FONT=Verdana]%USERPROFILE%\Documents[/FONT]

[FONT=Verdana]PrintHood[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Pr inter Shortcuts[/FONT]

[FONT=Verdana]Programs[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming\Microsoft\Windows\St art Menu\Programs[/FONT]

[FONT=Verdana]Recent[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Re cent[/FONT]

[FONT=Verdana]SendTo[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Se ndTo[/FONT]

[FONT=Verdana]Start Menu[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming\Microsoft\Windows\St art Menu[/FONT]

[FONT=Verdana]Startup[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming\Microsoft\Windows\St art Menu\Programs\Startup[/FONT]

[FONT=Verdana]Templates[/FONT]
[FONT=Verdana]%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Te mplates[/FONT]

Last edited by Prog-Rocker; 07-14-2009 at 03:47 PM.
Prog-Rocker is offline   Reply With Quote
Old 07-15-2009, 09:00 AM   #4
wallin99
Junior Member
 
Join Date: Jul 2009
Posts: 4
Default

Hi, have exactly the same problem!
I can find into the " User Shell Folders" as you mentioned.
I can also find all the Per-User special folders as you're talking about.
The problem is that in top the're is one with
name: (standard)
Type: Reg_SZ
And the "data" slot is empty.
What should I type here?
wallin99 is offline   Reply With Quote
Old 07-15-2009, 10:10 AM   #5
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,459
Default

wallin -

no need to change that one as it's the 'default' and should be blank

the "c:\users\?\" in your folder path should be your userprofile environment-variable.

check to see what the system thinks it is:

start / run
cmd
set
(look for the "userprofile" setting near the bottom of the list)
Prog-Rocker is offline   Reply With Quote
Old 07-15-2009, 10:38 AM   #6
wallin99
Junior Member
 
Join Date: Jul 2009
Posts: 4
Default

didn't really understand that.
Went into regedit again, under HKEY_Current_user I found Volatile environment, and under that i found this:

Name: Userprofile
Type: Reg_sz
Data: C:\users\

There was also one:
Name: Username
Type: Reg_sz
Data: (this was blank).

Now i understood it!

Wrote "Set" in cmd
The things that came up that looked important to this:

Public=C:\users\public
Username:?
Userprofile=C:\Users\?

So wghat should i change, where sohuld i change it and how

Last edited by wallin99; 07-15-2009 at 10:42 AM.
wallin99 is offline   Reply With Quote
Old 07-15-2009, 03:29 PM   #7
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,459
Default

that info is controlled by your windows login. the "?" should be the name you login to windows with but i don't know where that info is stored. it's also probably encrypted too because of the password that goes along with it. you can try starting with c-panel/user accounts.

you can also try posting in the MS forum. [URL]http://social.technet.microsoft.com/Forums/en-US/category/windowsvistaitpro[/URL]
Prog-Rocker is offline   Reply With Quote
Old 07-15-2009, 04:14 PM   #8
wallin99
Junior Member
 
Join Date: Jul 2009
Posts: 4
Default

Hm didn't really understand that :P
My windows login is wallin99 i believe.
What did yyou mean with "you can try starting with c-panel/user accounts."
(sry but dunno much bout pc's).
wallin99 is offline   Reply With Quote
Old 07-15-2009, 04:24 PM   #9
wallin99
Junior Member
 
Join Date: Jul 2009
Posts: 4
Default

Can happily present that i somehow fixed it!! =D
The steps i did:
Change in regedit:
Volatile environment-->
Change username to windows login and userprofile to end with windows login.
In cmd i changed it to end with windows login on both places, THEN i had to open ventrilo as administrator andthe changes took place, thx verymuch for your help m8! =)
wallin99 is offline   Reply With Quote
Old 07-15-2009, 08:20 PM   #10
Kirisi
Junior Member
 
Join Date: Jul 2009
Posts: 2
Smile

I just wanna say a big thanks to all the guys for the help,Im guna try this when i get home tonight
Kirisi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 09:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.