Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Macintosh Client

Reply
 
Thread Tools Display Modes
Old 10-29-2009, 12:29 PM   #1
Janil
Junior Member
 
Join Date: Oct 2009
Posts: 2
Default Unable to Connect to Server

I cannot contact the server, of which I have checked that I have the correct ip, port and password. I only see the text "MSG: Contacting server." and nothing else. Even if I turn off my firewall this is all I can see.

I can however telnet to the server and 'tcpdump host $IP' shows that the server does respond and these packets are not intercepted:
$ sudo tcpdump -i en2 host $IP
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on en2, link-type EN10MB (Ethernet), capture size 96 bytes
18:27:14.127643 IP $MYIP > $IP.$PORT: UDP, length 200
....

'tcpdump' also shows that Ventrilo is sending packets to $IP but the to these the server gives no reply. Any help?
Janil is offline   Reply With Quote
Old 11-06-2009, 04:30 PM   #2
mjgraf
Senior Member
 
mjgraf's Avatar
 
Join Date: May 2005
Location: Some say in my own little world
Posts: 15,502
Default

try to telnet to the server using the server ip and port.
mjgraf is offline   Reply With Quote
Old 11-09-2009, 02:16 PM   #3
Jaycyn
Senior Member
 
Join Date: Mar 2009
Location: Florida
Posts: 313
Default

See this thread and try what I suggested.

http://www.ventrilo.com/forums/showthread.php?t=40328
Jaycyn is offline   Reply With Quote
Old 11-19-2009, 02:28 PM   #4
Janil
Junior Member
 
Join Date: Oct 2009
Posts: 2
Default

Yes, tried that the link Jaycyn, thanks. Cannot connect there either. I know something is blocking me and as I said I can connect to the server with telnet.
Janil is offline   Reply With Quote
Old 11-19-2009, 06:57 PM   #5
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,463
Default

since the telnet worked that indicates the TCP is getting thru. so it looks like the UDP port is getting blocked.

the tcpdump should show an ack from the server on the UDP port. which is what happens if the vent window shows 'server is available'

if you have a router, check the log file there to see if the UDP packets are making it thru.

also try hooking the mac directly to the modem. power off the modem before connecting directly as it has to clear the router mac address.

i used:
tcpdump -i en1 port

make sure you only have 1 eth port active. disable all others.
Prog-Rocker is offline   Reply With Quote
Old 11-26-2009, 04:54 PM   #6
Aglyday
Junior Member
 
Join Date: Nov 2009
Location: USA
Posts: 1
Default Unable to Connect to Server

since yesterday i started getting the unable to connect to login server, i reinstalled and good, but after a while the connection with the server is lost and i cant get online again...so after 3 reinstallments its getting on my nerves...any ideas???
Aglyday is offline   Reply With Quote
Old 11-27-2009, 01:26 PM   #7
Jaycyn
Senior Member
 
Join Date: Mar 2009
Location: Florida
Posts: 313
Default

Can you connect to any other server - the one mentioned in the troubleshooting guide?
Jaycyn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.