Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 06-09-2010, 01:22 AM   #1
MusicTag
Junior Member
 
Join Date: Jun 2010
Posts: 1
Default Music Threw Vent

Hello everyone, I have a few questions about running music threw vent with Window 7, Ive been able to get to music threw vent by placing a mic next to headset speakers. I would like to be able to set it up where I dont have to do that and let it stream threw freely. Does anyone know how to do this?

Im running Ventrilo 3.0.5 (WIN32) on a 32-bit OS system type, and from what Vent Mixer is telling me i have "Digital Audio (S/PDIF)(High Definition Audio).

If you can help, I would greatly appreciate it. Thank you.

I also forgot to mention I'm using itunes.

Last edited by MusicTag; 06-09-2010 at 10:49 AM. Reason: Forgotten Information
MusicTag is offline   Reply With Quote
Old 06-09-2010, 11:10 AM   #2
PaPa t
Junior Member
 
Join Date: Jun 2010
Location: Durand Mi
Posts: 1
Cool Music

I 2 would like to use this service. I was in a guild that had a channel just for music I use usb heaad phones. I use window 7, love it, so much better than the other system out there. I play my music through windows media player. I just need to know how to add a stream from the media player to the vent client to both play my music and voice chat at the same time???
so far I have not found any teck links on how to do this???
any help would be greatly apreciated.

PaPa T
PaPa t is offline   Reply With Quote
Old 06-09-2010, 11:48 AM   #3
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,459
Default

start with these settings:

Setting up a DJ Connection

(Windows XP)

Here are some generic instructions. Your settings may vary depending on soundcard configurations, and drivers.

you will need 2 sound devices, either 2 soundcards, or, 1 soundcard and a usb headset.

configure vent to run multiple instances, one for music and one for regular talking.
rt-clik on the vent desktop icon > properties > add a -m to the end of the 'Target' line.

(ex: "C:\Program Files\Ventrilo\Ventrilo.exe" -m) the space before the -m is required

configure the music instance with a different login name so you can tell them apart when connected.
(note: if you ever need to make configuration changes, exit all copies, startup one, make the changes, then exit and restart all copies of vent)

in vent setup/voice tab, the music soundcard should be configured to 'use directsound' on both input/output devices and the device name should be that soundcard name (do not set it to a USB Headset name).

configure the hardware mixer section to the same sound device as set in the ‘Input Device’, mux=recording and line={‘stereo mix’, 'what-you-hear' or something similar}.

In vent setup/events tab, set all events to “Nothing”

set sensitivity=1 or 0 and uncheck PTT

on the main screen, check the 'mute sound' box at the bottom

note: if you don’t want to listen to the music coming back thru vent then on your talking client select the music client > rt-click > user > mute

(Windows Vista/Win7)

(Settings for onboard soundchip. Addin soundcards usually provide their own control-panel app)

configure vent to run multiple instances, one for music and one for regular talking.
rt-clik on the vent desktop icon / properties / add a -m to the end of the 'Target' line.

(ex: "C:\Program Files\Ventrilo\Ventrilo.exe" -m) the space before the -m is required

configure the music instance with a different login name so you can tell them apart when connected.
(note: if you ever need to make configuration changes, exit all copies, startup one, make the changes, then exit and restart all copies of vent)

goto Windows-control-panel / sound / Recording tab / rt-click in window / check ‘show disabled devices’ / rt-click on ‘Stereo Mix’ and select ‘properties’ / Levels tab / set volume level (50%) / Advanced tab / select ‘2 channel 44 Hz’ in pulldown window’ / click OK

select Playback tab / rt-click on ‘Speakers’ and select ‘properties’ / Levels tab / mute the microphone and any other jacks that are not in use (click on the little speaker icon next to each one)

reboot to make sure settings are in effect

in vent setup/voice tab, set both input/output devices to the device name of the soundcard (ex: Realtek…) and check the ‘Use Directsound’ boxes

in the hardware mixer section, set Mixer=Stereo Mix, mux=Master Volume, and line=Master Volume
(use the ‘line volume’ slider to adjust the microphone output volume)

set sensitivity=1 or 0 and uncheck PTT (setting sensitivity=1 will stop broadcasting during times of no outgoing signal, like in-between songs or if you pause/stop the music. It will also help flush the buffers)

In vent setup/events tab, set all events to “Nothing”

on the main screen, check the 'mute sound' box at the bottom

note: if you don’t want to listen to the music coming back thru vent then on your talking client select the music client > rt-click > user > mute
Prog-Rocker is offline   Reply With Quote
Old 07-25-2010, 10:18 PM   #4
Tezath
Junior Member
 
Join Date: Jul 2010
Posts: 7
Default Another streaming problem.

I myself use to stream music over vent all the time. Even WoW scripted sounds when my friends and I played. Now however I cant seem to stream anything at all. Sorry no pics but im using a self installed soundblaster audigy on vista and there never has been a what you hear option or stereo mix, only an auxiliary and thats what I use to use to stream. Biggest change I've done is added a usb headset but im not trying to stream with it. Even when I use my old headphones its no good too. vista OS, dell 420 xps with stigmatel onboard as well. If offers nothing. All devices are shown. When I do set it to aux it act right no errors or anything just no sound. Not muted in settings. Any ideas?
Tezath is offline   Reply With Quote
Old 07-26-2010, 05:42 AM   #5
Maelthras
Junior Member
 
Join Date: Jul 2010
Posts: 4
Default

This is easy, all you must do it open up the play control from taskbar, the little speaker at the bottom of your screen that is your sound. Go into options>properties, select your current output and go to recording, swap from microphone to record master and it will play whatever you would through your speakers directly through vent when you key up.
Maelthras is offline   Reply With Quote
Old 07-26-2010, 11:16 AM   #6
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,459
Default

question, is 'record master' the sigmatel option equivalent to 'stereo mix' ?
Prog-Rocker is offline   Reply With Quote
Old 07-26-2010, 03:02 PM   #7
Tezath
Junior Member
 
Join Date: Jul 2010
Posts: 7
Default

Ok, if I understand correctly im basically going into the recording devices tab and choosing record master. However that option is not there. I do have show disabled devices on and everything. Most im getting is mic, aux, line in, and s/pdif for the soundblaster and mic, speakers, line in for stigma. Well mic for usb too but that doesnt matter. Am I on the right page or did I misunderstand?

Last edited by Tezath; 07-26-2010 at 03:11 PM.
Tezath is offline   Reply With Quote
Old 08-27-2010, 10:48 PM   #8
Tezath
Junior Member
 
Join Date: Jul 2010
Posts: 7
Default

Guess im bumping here but still wondering if anyone has a solution. Just not sure how I go from streaming this way for years then boom nothing.
Tezath is offline   Reply With Quote
Old 08-28-2010, 01:21 PM   #9
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,459
Default

what model is the soundblaster, as most of them include a 'what-u-hear' option which is equivalent to 'stereo mix'
Prog-Rocker is offline   Reply With Quote
Old 08-28-2010, 05:42 PM   #10
Tezath
Junior Member
 
Join Date: Jul 2010
Posts: 7
Default

SB audigy, and it has up to date drivers so my system tells me anyways. I tried a roll back on them and that didnt help either. Was worth a shot. Only info i get on it is sb audigy, driver version 5.12.1.2020, 10/16/2009.
Tezath is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 05:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.