Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Macintosh Client

Reply
 
Thread Tools Display Modes
Old 01-05-2008, 02:07 PM   #1
Xiebinrui
Junior Member
 
Join Date: Nov 2007
Posts: 5
Default Sound output problems with new keyboard

Grrr...guess I gotta type this all over again, 'cause my session expired and I had to log back in again. Tried to backtrack a page to copy my post, but it wouldn't go back to the right page. Didn't realize I took so long. Oh, well, anyway...

I just got a new keyboard for Christmas: the i-Rocks EL X-Slim Keyboard (KR-6810M). It's a white keyboard with light blue backlighting behind the keys that you turn on using a silver button in the top right corner. Looks pretty cool, and I was looking forward to using it. I plugged it in and started playing around with it for the first time last night, and it worked great...until it came time to launch Ventrilo for a WoW raid. Now, every time I talk, people cry that I'm now making a loud beeping/whistling/whatever sound every time I try to say something (I use Push-To-Talk), and I don't know how to fix it. When I reattach the old keyboard, the loud extraneous sound goes away.

I tried to rule out other items, like my speakers, which were making a weird noise at first (they're a few years old and the connection isn't that great -- the subwoofer keeps humming more than it should until I jiggle the power cord in the back and actually unplug it slightly until the sound goes away).

Yeah...anyway, I tried different combinations of plugging the new keyboard into the cord extender that came with my G5 and plugging it straight into the back of the monitor without the extender. The only thing, however, that makes the loud sound go away is if I plug the old keyboard back in (Apple Extended keyboard with the black keys that came with my old G4 -- I liked it better than the one with the white keys that came with my G5).

Does anyone know what might be causing this problem and is there something that I could do to fix this so that I can use my new keyboard without that loud noise in Vent whenever I try to talk? (I've also posed the same question to i-Rocks support via e-mail in case the problem lies there, so I'll figure something out one of these days.)

I hear everyone else just fine, it's only when I actually try to say something.

Would it have anything to do with my Push-To-Talk? One thing to note is that the computer didn't recognize the keyboard at first and I had to press a couple keys to initialize it, but it then recognized it as a US-formatted keyboard (the keys are a little smaller and there's a slightly different layout to some areas, including 2 "ctrl" keys on the bottom left and the "help" key relocated to the right of the "ctrl" key to the right of the space bar).

Thanks for any help anyone can offer.

Xiebinrui, guild leader, Love and Peace, Crushridge

Dual-2.5 GHz Power Mac G5, Mac OS X 10.5.1, Ventrilo version 3.0.0
Xiebinrui is offline   Reply With Quote
Old 01-06-2008, 12:06 PM   #2
mjgraf
Senior Member
 
mjgraf's Avatar
 
Join Date: May 2005
Location: Some say in my own little world
Posts: 15,502
Default

you got me on this one.
I wonder if it may be something with the keyboard and 10.5 maybe. Let's hear from the manufacturer. it may be a bad keyboard.
mjgraf is offline   Reply With Quote
Old 01-07-2008, 02:43 PM   #3
Xiebinrui
Junior Member
 
Join Date: Nov 2007
Posts: 5
Default

Sounds good to me. Thanks for the quick response.
Xiebinrui is offline   Reply With Quote
Old 01-07-2008, 02:55 PM   #4
Xiebinrui
Junior Member
 
Join Date: Nov 2007
Posts: 5
Default

Oh, I did just find an online review of the keyboard, which did have this to say:

"Perhaps the biggest annoyance, at least for a silent computing freak like me, is that the keyboard emits a very irritating "humming" sound when the backlight is illuminated, sounding a bit like a hungry mosquito. Fortunately, the sound goes away when you turn the backlight off, and it's something I can live with when keyboard illumination is required, but it's also something the engineers should work on."

So it might just be the actual backlighting feature. Whee. No message from the i-Rocks folks just yet, but will post any info they provide.
Xiebinrui is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 04:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.