Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Closed Thread
Thread Tools Display Modes
Old 01-24-2008, 03:41 PM   #1
Flagship's Avatar
Join Date: May 2005
Location: Some insignifcant planet.
Posts: 8,059
Default Vista Quirks

I have started this thread to document some of the little quirks that I have noticed when running Ventrilo on MS-Vista. I'll add solutions where possible or later if a code change will help solve them.

1) If you have more then one sound input device like 2 sound cards, or a sound card and an external USB microphone. You happen to be in the Setup-Voice page and you click the Recording (Input) button to open the system sound control panel. Using the panel you switch what the default sound input device is and then you click either Monitor/Test button (or you click OK and return to main window) the program will pop a message saying "CreateCaptureBuffer failed" followed by a code or message.

This is not a program bug. It seems to be that the sound control panel is opening the device that you just set as the default in some kind of exclusive mode and when Ventrilo tries to open the device it can't because of the sound control panel still has exclusive ownership

Solution: After you select what you want the systems default sound input device to be then close the system sound control panel window and restart ventrilo and make what ever adjustments you need to from there.


2) Push-to-talk (PTT) and Bind keys don't work in certain games. Some games like BattleField 2 (BF2) have always required that you enable the DirectInput option in both Setup-Voice and for the bind list you are using, no matter what Operating System you were using. But some games, like Quake 3, will work fine without any special adjustments.

This is not a bug in the Ventrilo client. It is simply a quirk of the OS when certain games are running full screen and in exclusive mode (for lack of a better description).

Solution: In these cases, like BF2, you will need to run the Ventrilo client in Administrator mode. You can either right click on the Ventrilo Desktop icon and select "Run as administrator" or you can right click on the Ventrilo Desktop icon - select the Properties menu option - select the Compatibility tab - enable the "Run this program as an administrator" check box.

Last update: 1/24/08

Flagship Industries, Inc.

Last edited by Flagship; 01-24-2008 at 04:13 PM.
Flagship is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -5. The time now is 07:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.