Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 03-04-2011, 03:57 AM   #1
zad0909
Junior Member
 
Join Date: Jan 2009
Posts: 6
Default Ducking and locking up problem.

I have used ventrilo for quite a while. I love the new ducking feature. It's amazing.

I am having a problem with it though. Every time my friends talk the ducking works perfect. But when I talk there is no ducking. When I first got it my understanding was that the ducking feature worked when others and myself are talking/transmitting. I have 3.0.8 now and the problem is still happening. I have windows 7 64 bit.

Also some times when im using ventrilo it will lock up. I have push to talk on and it will freeze up and the client will have the green mic like im holding my PTT key but I'm not and the only way I've found to fix it is to restart the client. IS there a more permanent solution?
zad0909 is offline   Reply With Quote
Old 03-04-2011, 01:33 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,459
Default

the Devs are aware of the stuck ptt issue:

(my own opinion is that this arose from one of the recent windows updates as there have been reports of this happening with version 305, which has been in use for over a year)

you might try creating a special Bind key and set it to 'reset sound input device'

(from the release notes)
[FONT=Verdana]Some people have complained about a stuck PTT mode. This is not a bug in the program but the fault of the sound system which for some unknown reason stops sending sound to the program. The symptom will be the user pressed the PTT key and then let go but the speaker icon is still green and --XMIT-- is displayed. The client will now detect the loss of sound data from the input device and pop up a message when it occurs. It will also pop a different message if it detects the sound input stream has started again. At this time we are not sure if this is caused by the sound drivers or the Operating System. But we have confirmed that the sound device has stopped sending the program any sound stream data for some unknown reason. The developer was able to reproduce the problem on his development machine using the G930 headset but when they were moved to a different machine it worked perfectly. As it has been reported on different types of sound devices it leads us to believe the problem is in the OS or some piece of software installed on specific machines. Anyone who continues to experience this problem should list what software they have installed. Please be sure to have "Process priority class" in Setup-Misc set to high.[/FONT]
Prog-Rocker is offline   Reply With Quote
Old 03-06-2011, 12:41 AM   #3
zad0909
Junior Member
 
Join Date: Jan 2009
Posts: 6
Default

Ok thanks. Any ideas on what to do about my ducking problem?
zad0909 is offline   Reply With Quote
Old 03-08-2011, 03:26 PM   #4
zad0909
Junior Member
 
Join Date: Jan 2009
Posts: 6
Default

No ideas from anyone about why when I transmit my ducking doesn't work?
zad0909 is offline   Reply With Quote
Old 03-08-2011, 05:05 PM   #5
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,459
Default

sorry, no idea yet.

are there any error messages in the vent log file? rt-clik in window/view/log file/scroll to bottom

had you switched to voice-activation at any time?

what is the windows comm set to? clik on ducking then 'system comm panel' button

Last edited by Prog-Rocker; 03-08-2011 at 05:12 PM.
Prog-Rocker is offline   Reply With Quote
Old 03-08-2011, 06:10 PM   #6
zad0909
Junior Member
 
Join Date: Jan 2009
Posts: 6
Default

No I'm on PTT. Or push to talk.

I have never done anything but PTT. Never done that voice activated thing.

I'll attach a copy of my ducking settings and the vent log.





^ This is my ducking settings.

And my vent log has this over and over:
2011-03-03 01:16:34 CWaveInput: Start. Wave header list was not empty.
2011-03-03 01:16:34 EvtWimDone: waveHdrLst was empty. Not good!

As you can see it's not from today. So i dunno what it means.

Last edited by zad0909; 03-08-2011 at 07:08 PM.
zad0909 is offline   Reply With Quote
Old 03-11-2011, 01:47 PM   #7
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,459
Default

those errors usually suggest a problem with the audio drivers.

[FONT=Verdana]Check the Audio driver to make sure it is up to date. Or try re-installing the current driver.[/FONT]
[FONT=Verdana](note: some USB Headsets do not require a driver)[/FONT]
[FONT=Verdana](Don’t assume the driver is up to date as a newer one may have been released since the computer was built)[/FONT]
[FONT=Verdana] [/FONT]
[FONT=Verdana]- If you have a brand-name PC, like Dell or HP, then check the manufacturers website for driver updates.[/FONT]
[FONT=Verdana]- If you built the PC and use the on-board sound device then check the motherboard manufacturers website for drivers for your model motherboard.[/FONT]
[FONT=Verdana]- If you use a plug-in soundcard, ex: SoundBlaster, then check that manufacturers website for drivers.[/FONT]
[FONT=Verdana] [/FONT]
[FONT=Verdana]Also check for BIOS and chipset updates[/FONT]
[FONT=Verdana] [/FONT]
[FONT=Verdana]When checking for BIOS, chipset and certain onboard hardware drivers, you should only check the pc (or specific motherboard) manufacturers website for your make/model. The manufacturer is responsible for maintaining the proper version of driver for their specific hardware.[/FONT]
[FONT=Verdana] [/FONT]
[FONT=Verdana]For example: Realtek is an OEM manufacturer of audio chips and there are many different revisions of each. The latest driver found on the Realtek site may not be compatible with the version of chip in your pc, and could cause problems like 'stereo mix' to not be available. Realtek comments to this effect on their download page.[/FONT]
[FONT=Verdana] [/FONT]
Prog-Rocker is offline   Reply With Quote
Old 03-14-2011, 03:14 PM   #8
zad0909
Junior Member
 
Join Date: Jan 2009
Posts: 6
Default

Could all this be causing the ducking problem?
zad0909 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.