View Single Post
Old 07-26-2009, 06:17 AM   #8
Junior Member
Join Date: Jul 2009
Posts: 2

I'm the friend NeoLojik mentioned as also having the same problem. I run Ventrilo 3.0.4 (64bit) on Windows Vista Ultimate 64-bit. I've performed the same tests as him, using Iperf for Windows v1.70. The destination PC is on the same switch, and is running Windows Vista Business 32bit. This is what happens when I run Iperf with Vent running:

[116] local port 49787 connected with port 5001
[108] local port 49786 connected with port 5001
[ ID] Interval       Transfer     Bandwidth
[116]  0.0-30.0 sec   204 MBytes  56.9 Mbits/sec
[108]  0.0-30.0 sec   206 MBytes  57.6 Mbits/sec
[SUM]  0.0-30.0 sec   410 MBytes   115 Mbits/sec
And this is without Vent running:
[116] local port 49794 connected with port 5001
[108] local port 49793 connected with port 5001
[ ID] Interval       Transfer     Bandwidth
[108]  0.0-30.0 sec  1.14 GBytes   325 Mbits/sec
[116]  0.0-30.0 sec  1.10 GBytes   314 Mbits/sec
[SUM]  0.0-30.0 sec  2.23 GBytes   639 Mbits/sec
As you can see, it's a pretty significant performance hit. Bear in mind that this is only a *one-way* performance hit, too; if I rerun the tests in the other direction, it all works fine. This implies to me that Ventrilo is somehow affecting the RX (IE Download) bandwidth of the machine it's running on...

Further information if it's needed.
- The PC running Vent has an Asus P5K Premium Black Pearl edition mobo with an onboard Realtek RTL8110SC PCI Gigabit LAN controller. The drivers are the latest I could find, and are dated 25th May 2009. The problem occured with earlier driver versions.
- The destination PC has an Asus P5Q-EM mobo, running a Realtek 8111C PCI-E Gigabit LAN controller, drivers dated 3rd July 2009. Again, updating drivers update did not affect the problem.
- Both systems are connected to a a Netgear GS605 v2 gigabit-capable switch via known-working moulded-connector Cat5e.
- Both PCs show as connecting to the network at 1.0Gbit, and are perfectly stable at that speed.
- The RX and TX on both systems will allow for ~75-80MB/sec transfers (SATA II bottlenecks permitting) in both directions under normal operations.When the problem occurs, RX is limited to 14MB/sec.

So, does anyone have any ideas what NeoLojik and I could to to narrow down or solve this? Any help would be greatfully received.

Edit: I've updated to Ventrilo 3.0.5 (64bit), with no change to the problem.

Last edited by Kerrisis; 07-26-2009 at 06:39 AM.
Kerrisis is offline