View Single Post
Old 07-27-2018, 02:49 PM   #18
Junior Member
Join Date: Jul 2018
Posts: 1

I 'found' this query while I was trying to resolve the same error message, that is
CreateCaptureBuffer failed, HR=E_FAIL
which occurred not only when I opened Ventrilo on my laptop, but also when I opened TeamSpeak on my laptop. I could not 'speak' through either of them.
I am writing to advise you how I managed to get my mic working. It is an inboard microphone provided by the laptop manufacturer, so I assumed that there is no wiring errors, especially since it used to work.
Also, when trying to use Voice Recorder, it failed and said I should set up my microphone. A thought occurred to me that one of the things that has been floating around this last spring is updates to 'privacy' when it comes to cameras and microphones on laptops. I decided to check out the settings on privacy re microphone (yes there really is such a setting in Windows 10).
It appeared to be set properly, but the switches seemed to be frozen. I toggled the main switch off and on again, and the coloring on the switches changed. I said to myself "It can't be THAT easy". I tried to open Voice recorder, and the message about setting up my microphone was no longer there. Sure enough, I could record a small segment. and also sure enough, both TeamSpeak, and Ventrilo accepted voice just fine (I have them also set up on a desk top, so I could check them by connecting and speaking.)
I accept that you may have tried this and it may not work for you, but if you haven't, it is another thing to check. I note also that I DIDN'T have the same problem on my desktop. I suspect that there is a small difference in initialization between the two, something specific to laptop.
It continues to work just fine; I thought I should share, maybe it can help.
OldGuy4474 is offline   Reply With Quote