Ventrilo Tech Support

Ventrilo Tech Support (
-   Windows Client (
-   -   Cannot bind steam controller input to PTT (

axemd 12-29-2015 06:33 PM

Cannot bind steam controller input to PTT
Using v. 3.0.8, win7 64 bit. I've used xbox 360, xbone and ps4 controllers without issue. Anyone know if there is a fix?

Prog-Rocker 12-30-2015 09:21 AM

which control are you trying to bind?

have you tried re-mapping that control in steam setup to another keystroke then using that key combo in vent setup ptt?

are there any other controllers still plugged into the pc?

i've read in reviews that other controllers and/or the mouse can sometimes interfere with the steam.

axemd 12-30-2015 11:17 AM

I've tried binding any of the steam controller's buttons in-game without success. No other controllers are plugged in. Unfortunately, mapping other keys to the steam controller only works in "desktop" mode, so once I'm in a game on steam, those binds are overwritten and ventrilo does not recognize inputs from the steam controller.

Prog-Rocker 12-30-2015 11:41 AM

can you tell if your icon turns green when trying the ptt key while in game?

have you tried running both vent and the game in admin mode? rt-clik on their icons then select 'run as admin'

can you modify the steam controller profile just for that game?

Flagship 12-30-2015 03:12 PM

Is this on a steam console? if so which one. Or what controller and where to get one?

Flagship 12-30-2015 09:56 PM

I ran out to GameStop and bought one of these. Here's what I can tell you.

My gaming box is Win 8.1

It's not a traditional game controller like you would buy from Logitech.

Then what is it you ask? It's a handheld keyboard and mouse. Seriously!

Most of the buttons (not all) would show up in the binding window as keyboard clicks.


Mode 1:
 Right / Left trigger = Mouse 1/2
 Right / Left bumpers = Did not register
 Right / Left underside = Did not register
 Left pad = Keyboard up/down/right/left arrows
 Right pad = Mouse movement
 A = Return keyboard
 B = Escape keyboard
 X = Did not register
 Y = Did not register
 Left function arrow = Keyboard Tab
 Right function arrow = Keyboard Escape
 Joystick = Keyboard Up/Down/Left/Right

After reading some info on the web I discovered that I had to run an update on the controller.

1) Start Steam
2) Enter big picture mode
3) Should auto detect controller and ask to upgrade

After the upgrade the following now shows up.


 Left trigger = Mouse 2
 Right tigger = Mouse 1
 Left bumper = Keyboard Left Control
 Right bumper = Keyboard Left Alt
 A = Keyboard Return
 B = Keyboard Space
 X = Keyboard Prior (Page up)
 Y = Keyboard Next (Page down)
 Left underside = Mouse 4
 Right underside = Mouse 5
 Left pad no longer registers each direction. Just a single Mouse 3.
 Right pad when pressed is Keyboard Left Shift.

I did notice one thing. In order for Left/Right triggers to be detected the cursor has to be hovering over the hotkey input box. Don't know why.

So, it does seem to work.

OK, let me add to this: After telling Steam to exit the system the controller buttons stopped working completely. Nothing... nada... zippo... the big goose egg... no sprechen sie deutsch.

I had to quit Ventrilo, turn the controller off for a second, turn it back on and then it works again but it's back in Mode 1 (See above).

Start Steam again and then it goes back to Mode 2 (See above).

Not even going to guess as to why they do this.


All times are GMT -5. The time now is 01:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.