Ventrilo Tech Support

Ventrilo Tech Support (
-   Windows Client (
-   -   Failed to open sound input device (

kidleaderkty 05-27-2018 06:50 PM

Failed to open sound input device
Running windows 10. Had no issues prior to the most recent update, and since then I have not be able to get my vent to pick up my microphone at all.

I've tried things outlined in previous threads (i.e. checking mic through windows, making sure device is enabled, vent input device set as directsound, etc.)

Failed to open sound input device. rc=-10, CreateCaptureBuffer failed. HR=E_FAIL. An undetermined error occurred

dxdiag is below and in following posts:
System Information
Time of this report: 5/27/2018, 19:19:43
Machine name: DESKTOP-MSAM4RF
Machine Id: {F213C23B-0339-4F78-AA6F-486F88642065}
Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
Language: English (Regional Setting: English)
System Manufacturer: MSI
System Model: MS-7978
BIOS: Default System BIOS (type: BIOS)
Processor: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz (8 CPUs), ~3.6GHz
Memory: 32768MB RAM
Available OS Memory: 32716MB RAM
Page File: 7307MB used, 30527MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.17134.0001 64bit Unicode

DxDiag Notes
Display Tab 1: No problems found.
Display Tab 2: No problems found.
Sound Tab 1: No problems found.
Input Tab: No problems found.

DirectX Debug Levels
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

Prog-Rocker 05-28-2018 12:12 PM

try this first:


if that doesn't work then can you post these sections from the dxdiag plz:

sound devices

sound capture devices

direct input devices

usb devices

ps/2 devices

greenstone 05-29-2018 09:32 PM

Fix found.
"Failed to open sound input device. rc=-10, CreateCaptureBuffer failed. HR=E_FAIL. An undetermined error occurred"

I just received this error on my vent after I was checking services in Windows 10.

Service that caused the error:
Capability Access Manager
Service Provides facilities for managing UWP apps access to app capabilities as well as checking an app's access to specific app capabilities.
(Make sure the above service is automatic if you have it.)

Found out that by switching it off it turns off the "privacy settings" for the microphone and various other items in the newest Windows 10 patch.

Look under "setting">"privacy">"microphone", make sure "Allow apps to access your microphone" is turned on to fix most microphone issues with the newest windows 10 patch.

LeeroyBro 05-31-2018 08:17 AM

I was having the same issue. This fixed my problem. Thank you so much!

itsalex 05-31-2018 09:02 PM

This is a relevant thread, maybe this could help.


alice2911 06-07-2018 04:24 AM

Once I reinstalled win, I had this problem. finally fix it

johnyjackson 07-16-2018 01:05 AM


Originally Posted by alice2911 (Post 4644261)
Once I reinstalled win, I had this problem. finally fix it

Thanks, After re-installation It's Works Great

baobiyenphat 09-04-2018 10:53 PM

This fixed my problem. Thank you so much

adamjackson14 06-06-2019 02:29 AM

Thanks for

techsupport90 07-25-2019 06:48 AM

During the time i have downloaded Ventrilo i have been getting rather annoyed with it. I cannot speak to my felloe guild members as this error message keeps popping up, Failed to open input device. Another program might have it open already. rc = -10... I've asked them for suggestions but everyone i have been given hasn't come clear to solving the problem.
I am using a Headset called Gembird AP-870.I have searched the web trying to find a solution but have found nothing that can help me.. If anyone knows how i can solve this i will be grateful.

Prog-Rocker 07-25-2019 02:51 PM

@ techsupport

(did you copy from this old post from 2010) [url][/url]

the input device refers to the microphone. are you running any other apps that require access to the mic?

also plz check the info 3 posts above

hoathinh01 07-26-2019 11:23 PM

Thanks for your article, I'm having this problem and it has been fixed

flfreedivers 07-30-2019 01:42 AM

Please follow the following steps:-
Open the classic Control Panel app.
Navigate to Control Panel\Hardware and Sound\Sound.
On the Recording tab of the sound dialog, select the desired input device from the list of available devices.
Click on the Set default button

Hope so your problem will resolve

barrysingh102 01-05-2020 01:11 PM

first, goto vent setup voice-binds-speech tabs and set the output/input devices to the actual name of the headset you're using.

set the hardware-mixer to 'none' and test. then try setting it to the same name as the input device.

clik the 'recording' button and disable all of the unused devices. rt-clik on a device and first enable both 'show' options. then select the unused devices and clik disconnect

Prog-Rocker 01-31-2020 10:58 AM


can you please provide more details for you problem

thanhtung 03-23-2020 05:15 AM

Thank you very much, it helped me solve the problem.

brittanymarshel 04-19-2020 01:19 PM

I have tried following the advice and after reinstalling the problem is fixed.

richlong5012 06-16-2020 07:51 AM

1. Make sure the service called "Capability Access Manager Service" is set to automatic and is running.

2. Make sure you look under windows 10 settings > privacy > microphone and turn on "Allow apps to access your Microphone".

ParsonJ 06-19-2020 08:54 AM

I have the same problem

conglyvaness 09-06-2020 09:48 PM

This fixed my problem. Thanks!

xpaceseven 10-16-2020 02:27 PM

I am having trouble using vent with my new SWTOR Razer headset. I had no problems over the weekend, but starting yesterday I got this error:
Failed to open sound input device. rc=-10, CreateCaptureBuffer failed. HR=E_FAIL. An undetermined error occurred.
Through a series of steps - including restarting vent, restarting SWTOR, unplugging the headset and more - I am able to get the headset and mic to work for about 10 minutes. Then, all of my audio disappears and I get the error. I have tried different USB ports although not the ones my keyboard and mouse are plugged into, and those have never failed.

Prog-Rocker 10-16-2020 04:04 PM


What version of windows are you running?
what version of vent? 3 or 4

the 'CreateCaptureBuffer failed' indicates a problem with the microphone.

in vent setup, set the input device to the razer mic name

try disabling all other redording devices:
Windows Control-Panel > Sound > Playback & Recording tabs > rt-click in the window and select "Show Disabled Devices" and "Show Disconnected Devices" > rt-click on all unused devices and select "disable"

check with razers support site for any firmware updates for the headset

also check the pc's support site for any BIOS, chipset, audio driver updates

maxwelll 03-31-2021 07:46 PM

i can not get my mic to work . just stopped working 2 days ago i need help

Prog-Rocker 04-01-2021 08:59 AM


what version of windows are you running?

test the mic with the windows sound settings

All times are GMT -5. The time now is 01:28 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.