Ventrilo Tech Support

Ventrilo Tech Support (
-   Windows Client (
-   -   Connection closed by foreign host. (

YINNY 08-08-2012 12:56 PM

Connection closed by foreign host.
Ventrillo is stuck in the contacting server stage, upon doing a trace route I get "Connection closed by foreign host." I know I am not banned from the server and this is happening to me across ALL ventrillo servers.

I am in South Africa

My router has no firewall on, nor does my computer

I am tech savvy (oh so 133t :( ) and I have tried absolutely everything.

Please help.

Prog-Rocker 08-08-2012 01:33 PM

can you telnet to any of your servers?

[FONT=Verdana]start > run[/FONT]
[FONT=Verdana]cmd {hit enter}
telnet serverhostname port#


[FONT=Verdana](where serverhostname={the server ipaddress or hostname of the server you’re trying to connect to (found in vent client server setup)} and port#={port associated with that server}[/FONT]
[FONT=Verdana](example: “telnet 3784” or “telnet [url][/url] 3784” without the quotes)[/FONT]
[FONT=Verdana] [/FONT]
[FONT=Verdana]If Telnet is able to connect then the screen will go blank. If not, then you will see an error message about not being able to connect.[/FONT]
[FONT=Verdana] [/FONT]
[FONT=Verdana]Enabling Telnet in Vista/Windows 7[/FONT]
[FONT=Verdana] [/FONT]
[FONT=Verdana]Control-Panel / Programs and Features / Turn Windows features on or off / select “Telnet Client” / click OK[/FONT]
[FONT=Verdana] [/FONT]
how far does the traceroute get?

'connection closed' sounds like the connection is getting blocked somewhere along the netpath

YINNY 08-08-2012 05:03 PM

Telnet works fine.

Below is how far the trace route goes.

1 <1 ms <1 ms <1 ms
2 9 ms 9 ms 9 ms []
3 44 ms 10 ms 10 ms[]
4 10 ms 10 ms 10 ms[]
5 * * * Request timed out.
6 14 ms 11 ms 12 ms
7 11 ms 11 ms 11 ms []
8 201 ms 201 ms 200 ms []
9 401 ms 394 ms 383 ms []
10 199 ms 202 ms 198 ms []
11 202 ms 256 ms 203 ms []
12 267 ms 269 ms 267 ms []
13 289 ms 286 ms 284 ms []
14 298 ms 298 ms 298 ms []
15 311 ms 305 ms 354 ms []
16 304 ms 308 ms 304 ms []
17 303 ms 303 ms 304 ms []
18 304 ms 327 ms 303 ms [] Trace complete.

This is the original I.P. I'm trying to connect to.

Prog-Rocker 08-08-2012 06:40 PM

ok, the telnet tells me that the TCP connection is OK so it must be the UDP that's getting blocked. and the trace is getting all the way through. try temp disabling all firewall/virus/spyware/malware apps. also check the taskmanager processes/services pages for any other stubs of those apps that might still be running even tho you disabled or deleted. if you find any then goto that manufacturers website to see if they have a removal tool.

also try booting into safe-mode w/networking:

[FONT=Verdana]Restart Windows[/FONT]
[FONT=Verdana]Keep hitting the F8 function key before the Windows logo appears. You should see a list of options to choose from. [/FONT]
[FONT=Verdana]Select “Safe Mode with Networking”. This will boot windows into a very basic configuration but also allow network drivers to load.[/FONT]

[FONT=Verdana]Start Ventrilo to see if it connects all the way. If it works properly then there is something that is loading during the normal boot that is interferring with the connection.[/FONT]

[FONT=Verdana]netsh winsock reset all[/FONT]

[FONT=Verdana]Open an elevated command prompt. To do this, click Start, click All[/FONT]
[FONT=Verdana]Programs, click Accessories, right-click Command Prompt, and then click Run[/FONT]
[FONT=Verdana]as administrator. If you are prompted for an administrator password or for a[/FONT]
[FONT=Verdana]confirmation, type the password, or click Allow/Continue.[/FONT]

[FONT=Verdana]Type in the following command:[/FONT]

[FONT=Verdana]netsh winsock reset all[/FONT]

YINNY 08-09-2012 04:43 PM

Nope and nope.

Thanks for all the help so far, but none of it is working.

I've reinstalled vent multiple times and even deleted any data related to vent before reinstalling still to avail.

Prog-Rocker 08-09-2012 05:32 PM

the problem is not with vent but with something blocking the network connection on the netpath. as a test, you can try connecting thru a proxy service. you will have to configure it for your servers port# (TCP & UDP) as well as port 6100 UDP.

have you tried resetting your modem/router? or even a factory reset of the router?

All times are GMT -5. The time now is 05:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.