Ventrilo Tech Support

Ventrilo Tech Support (
-   Server (
-   -   Windows Server 2012 (

astrozombee 07-01-2013 03:17 PM

Windows Server 2012
Recently Upgraded my work server OS from Win Server 2003 to Win Server 2012.
Vent Server worked flawlessly as a service on win server 2003 for years.

I have the service installed and running on Windows server 2012.
I can only connect to it on the server itself using localhost for the address.
Using internal ip's locally doesn't work, nor does using my public ip outside the network.

I have 3784 udp forwarded
3784 tcp forwarded
6100 udp forwarded all to the appropriate address.

Using a Cable Modem/Router SMCD3G-CCR from Comcast

the Ventrilo Status web page shows my server up and running.

The client says server is available, but is unable to connect.

Firewall rules have been made, even tried disabling the firewall, and using the dmz
all had the same result,

Clients can tell that the server is there, it just doesn't respond properly upon attempting to connect.

Prog-Rocker 07-01-2013 03:51 PM

looks like the UDP packets are getting thru, since the status page works. try telnetting from a local lan pc as it sounds like the 3784TCP packets are getting blocked at the pc.

telnet {ipaddress} 3784

Prog-Rocker 07-01-2013 04:03 PM

also checkout the notes for win servers here -

html is currently off so it may be hard to read.

also, my telent was able to get thru but the client just won't connect all the way

astrozombee 07-01-2013 04:08 PM

When I telnet in, it connects, then says press any key to continue, then kicks me back to the cmd prompt screen.

Prog-Rocker 07-01-2013 04:19 PM

that's normal for a telnet session.

and the server seems to be working since you can connect locally from the same pc. I suspect it's something running on the server pc that's preventling any connections from other pc's.

have you tried temp disabling firewall/virus/spyware/malware apps ?

astrozombee 07-01-2013 06:26 PM

Ok, I figured it out, My Domain Group Policy was overriding my Firewall rules. I had to make a new Group Policy object and add the Firewall rules there.

astrozombee 10-08-2013 05:45 PM

So, this problem has come and gone and I have finally gotten to the bottom of it.

There was a port conflict within my services.
svchost.exe (netsvcs) was also trying to use port 3784 tcp
to be more specific it was iphlpsvc in the services which is run by the svchost.exe

Prog-Rocker 10-09-2013 08:58 AM

thanks for the update. i didn't expect a port conflict as 3784 is relatively obscure.

All times are GMT -5. The time now is 07:05 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.