Ventrilo Tech Support

Ventrilo Tech Support (http://forum.ventrilo.com/index.php)
-   Server (http://forum.ventrilo.com/forumdisplay.php?f=8)
-   -   Proposal: a server test service (http://forum.ventrilo.com/showthread.php?t=41631)

larri 01-31-2010 05:39 AM

Proposal: a server test service
 
Hi,

how do you confirm that your own server setup (especially the port forwarding) works as intended? I mean, I can access my server from within my LAN, and I think I have opened all the right ports ion the firewall - but how can I get a confirmation? I've found uncountable sites that offer open servers with which we can test that our clients are working, but i haven't found one site (yet) where I could enter my server URL, for example, and have a machine call my machine back to test the connection - such a service would be a great help!

In the meantime, if anybody can help me by trying to connect, I'd appreciated it. The current server URL (this will change as soon as the test has been positive) is {removed}

Many thanks!

Larry

mjgraf 01-31-2010 01:24 PM

use www.ventrilo.com/status.php

if the status program can connect, then you should have a correctly configured server.

larri 02-01-2010 07:11 AM

Quote:

Originally Posted by mjgraf (Post 147553)
use www.ventrilo.com/status.php

if the status program can connect, then you should have a correctly configured server.

Many thanks! Actually, right after posting here, I stumbled right on to that service (the word "status" had never tempted me to click, but I hit it accidentally). Oh, well... ;-)

Maybe it's just my odd self, but to feel tempted to click I need links that say, for example, "Your IP" and "Test your server". :-)

Anyway... one of the useful things I found out is that setting up port forwarding (3784, 6100) in my router made no difference - I had to disable the firewall to make my server accessible. Odd, very odd.

Larry

mjgraf 02-01-2010 02:15 PM

you most likely need to add an exception to the firewall to allow it to pass instead of disabling it completely.

larri 02-01-2010 11:55 PM

Thanks for the additional information.

The router has 5 settings: high, medium, low protection, firewall off, user modification.
Since even "low" does not allow the traffic through, I had chosen "off".

Following your suggestion I chose "user modification" and set up port 3784 TCP & UDP as well as 6100 UDP, for both incoming and outgoing traffic - but still no luck. So I am back to "firewall off" and will call a service rep and ask them to tell me what to do. :-)

Added later: I did a web search, hoping to find some setup information from someone who previously went through the process, and I found a sample firewall setup for an HTTP server on the web and extrapolated from that what the settings for Ventrilo would have to be. Turns out the firewall settings are somewhat unintuitive (for example, although there is a field for "port on the WAN side" one should/need not enter anything there, etc.). Anyway, I followed the sample and according to "Status" the server can now be accessed.

Thanks again!

Larry


All times are GMT -5. The time now is 10:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.