Ventrilo Tech Support

Ventrilo Tech Support (
-   Windows Client (
-   -   Unable to open a decompression stream. Code = 8 (

Magictest 05-05-2015 12:27 PM

Unable to open a decompression stream. Code = 8
I can hear event sounds/play clicks, others can hear me, but I cannot hear other people talking. When I go into testing I get the error "Unable to open a decompression stream. Code = 8" for the GSM 6.10 Codec, but the Speex codec works fine.

I found a possible solution:[FONT=Verdana](Windows XP)[/FONT]
[FONT=Verdana]Control Panel > Sounds and Audio > Hardware Tab[/FONT]
[FONT=Verdana]Double click "Audio Codecs" > Properties Tab[/FONT]
[FONT=Verdana]Double click on msgsm32.acm[/FONT]
[FONT=Verdana]Click settings[/FONT]
[FONT=Verdana]Set Compress and Decompress to “All rates” [/FONT]
[FONT=Verdana]Press OK (4 times)[/FONT]
HOWEVER its for Windows XP.
I'm using windows 7, and I can't find a way to edit my codecs.
I have tried various solutions already:
-reinstalling GSM 6.10 codec through deleting/reinstalling windows media player but it did not reinstall the codec.
-c-panel / sounds / playback / select device / properties / advanced tab / select one of the 44khz settings. Still same decompression error.
-Reinstalled new version of Ventrillo.
-Copy/pasted a msgsm32.acm file from another computer where it works. Still same error.

Any help would be very appreciated

Prog-Rocker 05-05-2015 12:30 PM

have you recently installed any 3rd party codec packs?

Magictest 05-05-2015 12:32 PM

I didn't have any, and then my friend told me to try CCCP. I installed that but it didn't fix anything.

GSM 6.10 is a default windows codec and I cannot find any download of it(windows 7) online.

Prog-Rocker 05-05-2015 01:24 PM

ok, lets try this first:

Write down your Username(s) and Server information
exit vent
goto START/RUN and enter: %appdata%\ventrilo
right-click on ventrilo2.ini (located in the Ventrilo folder) and select “Rename”
give the file a different name
restart vent
re-enter your username and server/password information

then check these settings:

Open Windows Media Player
Click on “HELP” in the menu bar
Select “About Windows Media Player’
Click the “Technical Support Information” link
Scroll down to the ‘Audio Codecs” section and look for “Microsoft GSM 6.10 Audio Codec”

Verify the file (must be logged into Windows with Admin priviledges)

Start / Run
Sfc /scanfile=c:\windows\system32\msgsm32.acm

Check the registry for the following:

Start / run

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]

Magictest 05-05-2015 01:40 PM

Thanks for all the help prog!

For the scan: Windows Resource Protection did not find any Integrity Violations.

For registry: msacm.msgsm610 is there with the correct value.

For added info:
GSM 8KHz works..? (Altough horrible quality) But 11,22,44 KHz do not.
Other servers with speex codec work fine.

The overall problem is that I cannot hear other users talk. (green icons not yellow). Vent is not muted. I can hear ventrilo event sounds fine.

Prog-Rocker 05-05-2015 02:05 PM

ok, lets try troubleshooting fromt the audio driver side. can you post the following plz:


Start > Run

Click the 'Save All' button
File is saved to the desktop as "DxDiag.txt"
Copy/paste the information (up to, and including, the [PS/2 Devices] section) to the forum. The information might have to be separated into multiple posts due to the maximum character limitation.

in vent setup/voice-binds-speech tabs, set the output device to enable 'use directsound' then set the name in the dropdown box to the device you're using.

set the inbound amplifier to 0

Magictest 05-05-2015 02:49 PM


Formatting on this site is hard so I just used pastebin.

I reinstalled the newest sound driver (I already had it before) this morning and didn't do anything.

I have done every combination of direct sounds/devices and still no go.
Thanks for all your continued help.

Prog-Rocker 05-05-2015 04:19 PM

i'll continue to research this but in the mean time, have you tried doing a windows 'restore' to a previous point when it was working?

Magictest 05-05-2015 09:35 PM

Prog thanks for all the attempted help, seriously man. Much love. I think my codec is just some kind of messed-up and I'd need to reformat. Good news, I got a workaround as the server's codec was changed to speex.

Prog-Rocker 05-06-2015 08:47 AM

before doing a reformat you might want to try booting from the windows install cd and selecting repair. it might find some audio related files that may have become corrupted.

All times are GMT -5. The time now is 09:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.