Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 09-01-2009, 01:19 AM   #1
bigernoi
Junior Member
 
Join Date: Sep 2009
Posts: 2
Default Megalodon and Vent

i just got a new headset today, a razer megalodon, now other people can hear them selves speak when i hold down my PTT button. any one know how i can fix this?
bigernoi is offline   Reply With Quote
Old 09-01-2009, 03:36 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,340
Default

try these settings:

Basic Sound System Setup

(Windows XP)
Goto control-panel / sounds & audio / audio tab / volume button / select ‘options’ in the menu / check ‘advanced’ / select ‘properties’ / select ‘playback’ radio button / check all boxes
select ‘record’ radio button / check all boxes / click OK

In the playback list of devices – check the ‘mute’ box under Microphone. Close window

Click the volume button in the ‘sound recording’ section. If the check boxes display ‘Select’ then check the box under Microphone. If the check boxes display ‘Mute’ then check all boxes EXCEPT ‘Microphone’ and ‘Mute All’

(Windows Vista/7)
Goto control-panel / sound / Playback tab / select speaker device / click ‘properties’ / Levels tab / mute the microphone (click the little speaker icon to see the red circle) / also mute anything listed as ‘Pink-In

Other possible settings may be included with the sound card audio manager program.

Temporarily disable any other sound/voice altering programs (if in use)

Generic Voice Problems

Make sure your soundcard drivers are up to date.

- If you have a brand-name PC, like Dell or HP, then check the manufacturers website for driver updates.
- If you built the PC and use the on-board sound device then check the motherboard manufacturers website for drivers for your model motherboard.
- If you use a plug-in soundcard, like SoundBlaster, then check that manufacturers website for drivers.

In vent setup, try setting the input/output devices to ‘use directsound’ and setting the device name to the sound device you’re using. (also try different combinations of checking/unchecking ‘use directsound’)

In the ‘hardware mixer’ section > set mixer={sound-device name}, mux=recording (master volume), line=microphone (master volume)
Prog-Rocker is offline   Reply With Quote
Old 09-01-2009, 08:52 PM   #3
Thiefroku
Junior Member
 
Join Date: Aug 2009
Posts: 16
Default

This could be easy. If they hear themselves that means YOUR mic is picking up sound from YOUR headset. So turn your sound in your headset down or turn your mic sensitivity down. personally if i'm right turn your sound down so your mic isn't a pain
Thiefroku is offline   Reply With Quote
Old 01-21-2011, 12:53 AM   #4
FeralJim
Junior Member
 
Join Date: Jan 2011
Posts: 2
Default

I am bumping this ancient post. Having this exact same problem. Details below.

I am using Windows 7, a Razer Megalodon headset and the latest Realtek HD Audio Drivers for my Gigabyte EP43T-USB3.0 motherboard. Every time I use push to talk the other guys on vent are getting stereo mixed, they can hear everything I hear repeated through my mic. I've tested the hardware with Skype and it has nothing to do with mic sensitivity.

Here comes the irony, when I try to google this all I get are threads with W7 users all trying to desperately turn *on* Stereo Mix. Which has apparently been disabled for the vast majority of users due to copyright infringement issues. Catch is, I am one of the lucky ones that can actually see Stereo Mix in their list of sound devices.

It's disabled.

It can't be working anyway, because the Headset is USB and legit stereo mix isn't compatible with that. So I guess my question is, why the **** is it mixing and how can I disable it?
FeralJim is offline   Reply With Quote
Old 01-21-2011, 12:12 PM   #5
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,340
Default

@ feraljim

first set vent as shown here:

http://forum.ventrilo.com/showthread.php?t=43879

set the outbound amplifier to 0

check the windows sound recording properties for the headset to make sure there's no 'mic boost' option set and disable any effects like noise suppression, accoustic cancellation
Prog-Rocker is offline   Reply With Quote
Old 01-21-2011, 07:21 PM   #6
FeralJim
Junior Member
 
Join Date: Jan 2011
Posts: 2
Default

Thanks for the speedy reply Rocker.

I have configured my vent as requested, enabling direct sound in the three tabs and setting my outbound amp to 0.

So the headphone in question shows up both as an audio device and a recording one.

The recording properties don't have any options or effects, nothing to do with mic boost. Just a sliding scale of volume which I have set to 10%.

The sound properties have an enhancements tab with Bass Management, Speaker Fill, Room Correction and Loudness Equalization. All disabled.

In both properties on the advanced tab I have unchecked the option to "allow applications to take exclusive control of this device". Hope this helps.
FeralJim is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 04:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.