Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 04-17-2009, 06:49 PM   #1
lemunt
Junior Member
 
Join Date: Apr 2009
Posts: 1
Default How can i play music into vent?

I know other people can do it, but i'm not sure how to.
How do i set vent so it plays the music that i am playing on my computer? Becuase if i put the mic up to my speakers, it plays back through other peoples speakers in horrid quality, where as i was told if i manage to do this, it will be crystal clear.

Thanks

Btw, i'm not too good with PC's, so simple language would make it easier
lemunt is offline   Reply With Quote
Old 04-17-2009, 10:10 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 22,877
Default

Setting up a DJ Connection

(Windows XP)

Here are some generic instructions. Your settings may vary depending on soundcard configurations, and drivers.

you will need 2 sound devices, either 2 soundcards, or, 1 soundcard and a usb headset.

configure vent to run multiple instances, one for music and one for regular talking.
rt-clik on the vent desktop icon > properties > add a -m to the end of the 'Target' line.

(ex: "C:\Program Files\Ventrilo\Ventrilo.exe" -m) the space before the -m is required

configure the music instance with a different login name so you can tell them apart when connected.
(note: if you ever need to make configuration changes, exit all copies, startup one, make the changes, then exit and restart all copies of vent)

in vent setup/voice tab, the music soundcard should be configured to 'use directsound' on both input/output devices and the device name should be that soundcard name (do not set it to a USB Headset name).

configure the hardware mixer section to the same sound device as set in the ‘Input Device’, mux=recording and line={‘stereo mix’, 'what-you-hear' or something similar}.

In vent setup/events tab, set all events to “Nothing”

set sensitivity=1 or 0 and uncheck PTT

on the main screen, check the 'mute sound' box at the bottom

note: if you don’t want to listen to the music coming back thru vent then on your talking client select the music client > rt-click > user > mute

(Windows Vista)

(Settings for onboard soundchip. Addin soundcards usually provide their own control-panel app)

configure vent to run multiple instances, one for music and one for regular talking.
rt-clik on the vent desktop icon / properties / add a -m to the end of the 'Target' line.

(ex: "C:\Program Files\Ventrilo\Ventrilo.exe" -m) the space before the -m is required

configure the music instance with a different login name so you can tell them apart when connected.
(note: if you ever need to make configuration changes, exit all copies, startup one, make the changes, then exit and restart all copies of vent)

goto Windows-control-panel / sound / Recording tab / rt-click in window / check ‘show disabled devices’ / rt-click on ‘Stereo Mix’ and select ‘properties’ / Levels tab / set volume level (50%) / Advanced tab / select ‘2 channel 44 Hz’ in pulldown window’ / click OK

select Playback tab / rt-click on ‘Speakers’ and select ‘properties’ / Levels tab / mute the microphone and any other jacks that are not in use (click on the little speaker icon next to each one)

reboot to make sure settings are in effect

in vent setup/voice tab, set both input/output devices to the device name of the soundcard (ex: Realtek…) and check the ‘Use Directsound’ boxes

in the hardware mixer section, set Mixer=Stereo Mix, mux=Master Volume, and line=Master Volume
(use the ‘line volume’ slider to adjust the microphone output volume)

set sensitivity=1 or 0 and uncheck PTT (setting sensitivity=1 will stop broadcasting during times of no outgoing signal, like in-between songs or if you pause/stop the music. It will also help flush the buffers)

In vent setup/events tab, set all events to “Nothing”

on the main screen, check the 'mute sound' box at the bottom

note: if you don’t want to listen to the music coming back thru vent then on your talking client select the music client > rt-click > user > mute
Prog-Rocker is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.