Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Macintosh Client

Reply
 
Thread Tools Display Modes
Old 11-14-2008, 08:30 AM   #1
sanctus petrus
Junior Member
 
Join Date: Nov 2008
Posts: 8
Default Mac users can't hear or talk

Hi,

I am the leader of my clan and we use ventrilo as our official audio chat. I think Ventrilo is so much more superior in quality than Teamspeak. The only problem is that none of our Mac members can hear or talk in it. The only way to change that is by changing the codex to speex. But when I do that me and all our non-Mac users sound like robots (can't understand a word). I tried downloading the recommended BETA client for Windows but I couldn't find it anywhere.

Anyone knows what I am doing wrong?
sanctus petrus is offline   Reply With Quote
Old 11-14-2008, 11:15 AM   #2
wadesworld
Senior Member
 
Join Date: Nov 2005
Posts: 2,934
Default

What settings are you using for the Speex format?
wadesworld is offline   Reply With Quote
Old 11-14-2008, 12:17 PM   #3
sanctus petrus
Junior Member
 
Join Date: Nov 2008
Posts: 8
Default

It is currently set to: 11KHz, 16 bit



The other options are:

8KHz, 16 bit
22KHz, 16bit
44KHz, 16 bit

Should I change that?
sanctus petrus is offline   Reply With Quote
Old 11-14-2008, 12:39 PM   #4
wadesworld
Senior Member
 
Join Date: Nov 2005
Posts: 2,934
Default

Absolutely. I'd be willing to bet your GSM settings are much higher than 11khz - that's why it sounds better.

Speex and GSM sound nearly identical - when using identical settings.
wadesworld is offline   Reply With Quote
Old 11-14-2008, 12:46 PM   #5
sanctus petrus
Junior Member
 
Join Date: Nov 2008
Posts: 8
Default

Hmm ... I am not too bright with stuff like this. Do you mean change it to 44KHz?
sanctus petrus is offline   Reply With Quote
Old 11-14-2008, 12:54 PM   #6
wadesworld
Senior Member
 
Join Date: Nov 2005
Posts: 2,934
Default

Well, on second thought, I'm not sure where the numbers come from. Those aren't for Speex - there's no 44K option for Speex.

I'd recommend you use this setting for Speex:

Speex (16 KHz, 16 bit, 9 Qlty) 4344 bytes/sec

That's:

VoiceCodec = 3
VoiceFormat = 20

in the ventrilo_srv.ini file (remember to restart the server after changing the file) if you're using a personal server. If using a hosted server, use your host's control panel or contact their technical support.
wadesworld is offline   Reply With Quote
Old 11-14-2008, 11:15 PM   #7
sanctus petrus
Junior Member
 
Join Date: Nov 2008
Posts: 8
Default

Ok, I left the Codex on "Speex" and the Format on "16KHz, 16 bit, 9Qlty".

A message shows:

"The configuration has been saved. You will have to restart your game server for the changes to take effect."

So, I sent a Ticket to ClanPlant (the host that I am renting the channel from) and asked them to restart the server.

Hopefully this will work. Thanks.
sanctus petrus is offline   Reply With Quote
Old 11-15-2008, 11:54 AM   #8
sanctus petrus
Junior Member
 
Join Date: Nov 2008
Posts: 8
Default

It's fixed. You are my hero! Thx
sanctus petrus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 11:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.