Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Macintosh Client

Reply
 
Thread Tools Display Modes
Old 03-26-2008, 10:40 AM   #1
matthoff
Junior Member
 
Join Date: Mar 2008
Posts: 8
Default Kernel Panics in 10.5.2

Using Vent 3.0.1 under 10.5.2 on a MacBook Pro with a Logitech headset.
I get Kernel Panics randomly, but usually after vent has been connected to a server for at least an hour. This problem did no occur with Vent 3.0.0

------------------------------------------------------------------------------------
Tue Mar 25 19:30:17 2008
panic(cpu 0 caller 0x001A8C8A): Kernel trap at 0x0041f84d, type 14=page fault, registers:
CR0: 0x8001003b, CR2: 0x0000000c, CR3: 0x0144a000, CR4: 0x00000660
EAX: 0x00000000, EBX: 0x0479b300, ECX: 0x07f6e128, EDX: 0x289e7b8c
CR2: 0x0000000c, EBP: 0x289e7b08, ESI: 0x0479b308, EDI: 0x0479b310
EFL: 0x00010202, EIP: 0x0041f84d, CS: 0x00000008, DS: 0x23ac0010
Error code: 0x00000002

Backtrace, Format - Frame : Return Address (4 potential args on stack)
0x289e78f8 : 0x12b0e1 (0x457024 0x289e792c 0x13321a 0x0)
0x289e7948 : 0x1a8c8a (0x460550 0x41f84d 0xe 0x45fd00)
0x289e7a28 : 0x19eb67 (0x289e7a40 0x42456e 0x289e7b08 0x41f84d)
0x289e7a38 : 0x41f84d (0xe 0x289e0048 0x190010 0x7f60010)
0x289e7b08 : 0x41f105 (0x479b300 0x289e7b8c 0x0 0x0)
0x289e7b58 : 0x41fa86 (0x4796e40 0x41f7f0 0x289e7b8c 0x0)
0x289e7ba8 : 0x6155d9 (0x479b300 0x0 0x289e7c08 0x625b08)
0x289e7c08 : 0x619a11 (0x42f8000 0x7ba5bc0 0xa2434d7 0x0)
0x289e7c68 : 0x34b97bde (0x4811340 0x7ba5bc0 0xa2434d7 0x0)
0x289e7cd8 : 0x34b97ddd (0x8cc7800 0x2 0x1 0x6b)
0x289e7cf8 : 0x34b98056 (0x8cc7800 0x6b 0x5afd560 0x8cd9d6)
0x289e7d38 : 0x34b98156 (0x8cc7800 0x2b 0x0 0x5afd560)
0x289e7d88 : 0x878e64 (0x8cc7800 0x34bb0000 0x2ea2f010 0x9fb)
0x289e7df8 : 0x874c9f (0x854e000 0x7da8e08 0x9fb 0x3e96a0)
0x289e7e68 : 0x874169 (0x8f86200 0x9fb 0x83e5200 0x7c19578)
0x289e7ea8 : 0x43b29c (0x8f86200 0x9fb 0xd89 0x1)
Backtrace continues...
Kernel loadable modules in backtrace (with dependencies):
com.apple.driver.AppleUSBAudio(2.5.4b4)@0x34b89000->0x34baffff
dependency: com.apple.iokit.IOAudioFamily(1.6.4b7)@0x86a000
dependency: com.apple.iokit.IOUSBFamily(3.0.8)@0x60f000
com.apple.iokit.IOAudioFamily(1.6.4b7)@0x86a000->0x880fff
dependency: com.apple.kext.OSvKernDSPLib(1.1)@0x867000
com.apple.iokit.IOUSBFamily(3.0.8)@0x60f000->0x636fff

BSD process name corresponding to current thread: Ventrilo

Mac OS version:
9C31

Kernel version:
Darwin Kernel Version 9.2.0: Tue Feb 5 16:13:22 PST 2008; root:xnu-1228.3.13~1/RELEASE_I386
System model name: MacBookPro3,1 (Mac-F4238BC8)
------------------------------------------------------------------------------------
matthoff is offline   Reply With Quote
Old 03-26-2008, 11:10 AM   #2
Flagship
Administrator
 
Flagship's Avatar
 
Join Date: May 2005
Location: Some insignifcant planet.
Posts: 8,046
Default

Are you running any other programs at the same time, especially anything that might be monitoring the microphone?
__________________
Flagship Industries, Inc.
www.ventrilo.com
Flagship is offline   Reply With Quote
Old 03-26-2008, 12:27 PM   #3
matthoff
Junior Member
 
Join Date: Mar 2008
Posts: 8
Default

I am running World of Warcraft. I have vent set up to send the audio to my MacBook speakers and the microphone is set to my Logitech headset. I am not running another app that uses the microphone. I do have iChat running in the background but I don't use it while vent is open.

Last edited by matthoff; 03-26-2008 at 12:29 PM.
matthoff is offline   Reply With Quote
Old 03-26-2008, 02:43 PM   #4
Flagship
Administrator
 
Flagship's Avatar
 
Join Date: May 2005
Location: Some insignifcant planet.
Posts: 8,046
Default

Even though iChat isn't being used it could still be interacting with the microphone.

Shut it down before you play WoW and use Ventrilo, if only to see if that stops the kernel panics.
__________________
Flagship Industries, Inc.
www.ventrilo.com
Flagship is offline   Reply With Quote
Old 03-26-2008, 08:00 PM   #5
matthoff
Junior Member
 
Join Date: Mar 2008
Posts: 8
Default

It just did it again. I had WoW, Firefox and Vent running. Nothing else.
matthoff is offline   Reply With Quote
Old 03-27-2008, 12:05 PM   #6
Flagship
Administrator
 
Flagship's Avatar
 
Join Date: May 2005
Location: Some insignifcant planet.
Posts: 8,046
Default

I'm going to be working on the sound system to implement SFX for the Mac client over the next few weeks, and since I think this kernel panic is caused by the sound system implementation I'll take a look at it while I'm in there.

Strange, it worked fine until 10.5.2. Then again something might have changed in their specification and I didn't know about it.

In the mean time you might also go into setup-voice and uncheck "enable outgoing voice" option just to see if that prevents the panic. This of course will prevent you from transmitting but you will still receive voice streams.

Let me know if that helps as it would help to narrow down the search.

Thanks,
Flag
__________________
Flagship Industries, Inc.
www.ventrilo.com
Flagship is offline   Reply With Quote
Old 03-27-2008, 12:19 PM   #7
wadesworld
Senior Member
 
Join Date: Nov 2005
Posts: 2,934
Default

If you have a different headset plugged in, do the panics still happen?
wadesworld is offline   Reply With Quote
Old 03-29-2008, 02:32 PM   #8
matthoff
Junior Member
 
Join Date: Mar 2008
Posts: 8
Default

I don't own a different headset and the panics do not occur on a regular basis so it is very difficult to pin it down.
matthoff is offline   Reply With Quote
Old 04-02-2008, 03:32 AM   #9
Netherby
Junior Member
 
Join Date: Apr 2008
Posts: 1
Default Out going sound quality AND panics

Hello, I have the same problem on my MacBook using Logitech usb head-set. But not just panics, people also complain that my out-going transmissions randomly start echoing or sounding like a 'robot'.. If I use the sound test in setup, my transmission quality returns to normal, or if I close and restart ventrilo. This happens quite regularly and is very annoying.

Also after running ventrilo for a longer period it will cause a kernel panic, this takes an hour or more to happen, but it will always eventually happen and appears to be caused by transmitting, since if I leave the mic muted for long periods it doesn't panic, it's only when actually transmitting.

I don't run any games on this computer, only iChat, msn, mail and vent.
Netherby is offline   Reply With Quote
Old 04-02-2008, 09:34 AM   #10
wadesworld
Senior Member
 
Join Date: Nov 2005
Posts: 2,934
Default

Best thing for you guys to troubleshoot is to try a different headset.
wadesworld is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 06:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.