Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 01-28-2008, 11:08 PM   #1
Lav2k8
Junior Member
 
Join Date: Jan 2008
Posts: 2
Default how to play music in vent

Ok, I know that sound cards have an option to play what you hear. However, I have sennheiser pc155's with a usb soundcard, and I don't get that option. When I go to the mixer options, and change it to USB headset, I get an error. InputFindVolFader failed (-1) for non-Mux based mixer.

So is there a way I can play music through vent, or do I have to get a real sound card?

Thanks.
Lav2k8 is offline   Reply With Quote
Old 01-29-2008, 05:42 AM   #2
Thesuffering
Junior Member
 
Join Date: Jan 2008
Posts: 7
Default

When I do it people says it sounds great. I made this same post awhile ago however 1 or 2 of my options are different because I did not have them as options. Still works, sounds great.

Hardware INPUT MIXER (optional)
Mixer = Realtek HD aUDIO INPUT
MUX = RECORDING CONTROL
LINE = STEREO MIX

*You won't be able to speak when is set up like this, so remember to just change your line back to mic volume afterwards.*
Thesuffering is offline   Reply With Quote
Old 01-29-2008, 09:54 AM   #3
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 22,914
Default

also this:

Setting up a DJ Connection

Here are some generic instructions. Your settings may vary depending on soundcard configurations, operating system, and drivers.

you will need 2 sound devices, either 2 soundcards, or, 1 soundcard and a usb headset.

configure vent to run multiple instances, one for music and one for regular talking.
rt-clik on the vent desktop icon > properties > add a -m to the end of the 'Target' line.

(ex: "C:\Program Files\Ventrilo\Ventrilo.exe" -m) the space before the -m is required

configure the music instance with a different login name so you can tell them apart when connected.
(note: if you ever need to make configuration changes, exit all copies, startup one, make the changes, then exit and restart all copies of vent)

in vent setup/voice tab, the music soundcard should be configured to 'use directsound' on both input/output devices and the device name should be that soundcard name (do not set it to a USB Headset name). configure the hardware mixer section to the same card, mux=recording and line={‘stereo mix’, 'what-you-hear' or something similar}.

In vent setup/events tab, set all events to “Nothing”

set sensitivity=1 or 0 and uncheck PTT

on the main screen, check the 'mute sound' box at the bottom

note: if you don’t want to listen to the music coming back thru vent then on your talking client select the music client > rt-click > user > mute
Prog-Rocker is offline   Reply With Quote
Old 02-02-2008, 11:56 PM   #4
Lav2k8
Junior Member
 
Join Date: Jan 2008
Posts: 2
Default

That's the problem. I can't config the mixer.
Lav2k8 is offline   Reply With Quote
Old 02-04-2008, 02:10 PM   #5
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 22,914
Default

try this:

Goto control-panel / sounds & audio / audio tab / volume button / select ‘options’ in the menu / check ‘advanced’ / select ‘properties’ / select ‘playback’ radio button / check all boxes / select ‘record’ radio button / check all boxes / click OK

In the playback list of devices – check the ‘mute’ box under Microphone. Close window

Click the volume button in the ‘sound recording’ section. If the check boxes display ‘Select’ then check the box under Microphone. If the check boxes display ‘Mute’ then check all boxes EXCEPT ‘Microphone’ and ‘Mute All’

Other possible settings may be included with the sound cards setup program.

Temporarily disable any other sound/voice altering programs (if in use)
Prog-Rocker is offline   Reply With Quote
Old 03-01-2008, 08:05 PM   #6
lorelye
Junior Member
 
Join Date: Nov 2007
Posts: 10
Default

I might actually be able to find the answer to the tech problem, if you'd just tell me, what do you do to actually play the music? Otherwise it's all sound settings and mux errors, and I have no idea if I can fix it. Is there a movie or tutorial somewhere? How do you play the song? Open Winamp and it just magically plays through vent? There is no combination of settings in Setup that makes music play.
lorelye is offline   Reply With Quote
Old 03-01-2008, 11:09 PM   #7
sedrikk
Junior Member
 
Join Date: Dec 2005
Posts: 4
Default

Is there any way to do something like this with only one audio device?

Quote:
Originally Posted by Prog-Rocker View Post
also this:

Setting up a DJ Connection

Here are some generic instructions. Your settings may vary depending on soundcard configurations, operating system, and drivers.

you will need 2 sound devices, either 2 soundcards, or, 1 soundcard and a usb headset.

configure vent to run multiple instances, one for music and one for regular talking.
rt-clik on the vent desktop icon > properties > add a -m to the end of the 'Target' line.

(ex: "C:\Program Files\Ventrilo\Ventrilo.exe" -m) the space before the -m is required

configure the music instance with a different login name so you can tell them apart when connected.
(note: if you ever need to make configuration changes, exit all copies, startup one, make the changes, then exit and restart all copies of vent)

in vent setup/voice tab, the music soundcard should be configured to 'use directsound' on both input/output devices and the device name should be that soundcard name (do not set it to a USB Headset name). configure the hardware mixer section to the same card, mux=recording and line={‘stereo mix’, 'what-you-hear' or something similar}.

In vent setup/events tab, set all events to “Nothing”

set sensitivity=1 or 0 and uncheck PTT

on the main screen, check the 'mute sound' box at the bottom

note: if you don’t want to listen to the music coming back thru vent then on your talking client select the music client > rt-click > user > mute
sedrikk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.