Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Macintosh Client

Reply
 
Thread Tools Display Modes
Old 02-08-2008, 03:29 PM   #1
gramathy
Member
 
Join Date: Nov 2005
Posts: 80
Default Resource hogging?

TO be honest, i've used Vent for over a year and been very happy with it. However, just today something came to my attention. I was playing warcraft, and I noticed I was getting an obscenely high framerate compared to what I usually get, on the order of 50+% higher. Naturally, I was confused as I had not updated anything recently. So I spend a little while trying to figure out what had changed, to no avail. I start up ventrilo to talk to one of my guildmates -

- and my framerate immediately drops to the original level.

After a bit of experimentation, it was only when I actually connected to the server that my framerate would drop significantly.

I realize that Ventrilo has encoding and decoding to do, and my computer isn't exactly state-of-the-art (1.5GHZ G4 powerbook, 2GB RAM), but is it so significant as to eat up that much of my computer's power, and is there any way to reduce the load?
gramathy is offline   Reply With Quote
Old 02-08-2008, 09:06 PM   #2
mjgraf
Senior Member
 
mjgraf's Avatar
 
Join Date: May 2005
Location: Some say in my own little world
Posts: 15,502
Default

what is the speex format setting?
mjgraf is offline   Reply With Quote
Old 02-09-2008, 10:32 AM   #3
gramathy
Member
 
Join Date: Nov 2005
Posts: 80
Default

Currently 32/7.

Going to run some tests and report on what I see as the difference. Baseline will be vent off completely with headset plugged in but unused.

Tests:

Baseline - 28 fps (all framerates are average over an identical 3 minute timetest)
Vent open - 28 fps
Vent connected, using builtin mic - 24 fps
Vent connected, using USB headest - 21 fps
(builtin mic for all below)
Channel codec changed to 16/9 - 24
Channel codec changed to 32/5 - 24
Channel codec changed to 16/5 - 24
Server codec changed to 16/5 - 24

Seems like my USB headset was partially to blame, but vent is still killing ~12% of my baseline framerate regardless of codec quality. (used to be the 21 fps number, vent off 28 fps = ~35% increase. My original post was a result of me rounding the numbers, 20->30 is a 50% increase)

Last edited by gramathy; 02-09-2008 at 11:13 AM. Reason: Info
gramathy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.