Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 05-28-2018, 07:00 PM   #1
LeeroyBro
Junior Member
 
Join Date: May 2018
Posts: 3
Default Failed to open sound input device.

I was using Ventrilo 3.0.8 client without problems. When launching the client, I received the popup notification that there is a new version (4.0.1) available, so I downloaded it. After having some issues with the install (had to run as administrator), I successfully got 4.0.1 running. Unfortunately the server I was connecting to has not yet upgraded, so I went back to the 3.0.8 client that is still on my computer. Now I receive the following error:

Failed to open sound input device. rc=-10, CreateCaptureBuffer failed. HR=E_FAIL. An undetermined error occurred

Whenever I use the PTT key, the following error occurs:
Can not transmit because the program has not successfully opened a sound input device such as a desktop or headset based microphone. Please check your hardware configuration and any reported errors during connection.

I have checked that the headset works by plugging it into another computer. The headset is USB, so I also tried various ports on the computer. I have also verified that it is the default recording device for the computer. When I select "Listen to this device" under the "Listen" tab of the device properties, I can hear my voice through the speakers. I have also checked everything I could find online about the system registry. I'm not sure what to look for, so I didn't change anything. With all that said, the next post will include DXDIAG info. I appreciate any suggestions that you can offer.

Thanks
LeeroyBro is offline   Reply With Quote
Old 05-29-2018, 08:12 AM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,383
Default

first, goto vent setup voice-binds-speech tabs and set the output/input devices to the actual name of the headset you're using.

set the hardware-mixer to 'none' and test. then try setting it to the same name as the input device.

clik the 'recording' button and disable all of the unused devices. rt-clik on a device and first enable both 'show' options. then select the unused devices and clik disconnect

--------------

also, can you elaborate further on what type of error you were getting when trying to install version 4 using a non-admin acct.
Prog-Rocker is offline   Reply With Quote
Old 05-29-2018, 09:25 PM   #3
greenstone
Junior Member
 
Join Date: May 2018
Posts: 3
Default Found Fix

"Failed to open sound input device. rc=-10, CreateCaptureBuffer failed. HR=E_FAIL. An undetermined error occurred"

I just received this error on my vent after I was checking services in Windows 10.

Service that caused the error:
Capability Access Manager
Service Provides facilities for managing UWP apps access to app capabilities as well as checking an app's access to specific app capabilities.
(Make sure the above service is automatic if you have it.)

Found out that by switching it off it turns off the "privacy settings" for the microphone and various other items in the newest Windows 10 patch.

Look under "setting">"privacy">"microphone", make sure "Allow apps to access your microphone" is turned on to fix most microphone issues with the newest windows 10 patch.
greenstone is offline   Reply With Quote
Old 05-31-2018, 08:18 AM   #4
LeeroyBro
Junior Member
 
Join Date: May 2018
Posts: 3
Default

Quote:
Originally Posted by greenstone View Post
"Failed to open sound input device. rc=-10, CreateCaptureBuffer failed. HR=E_FAIL. An undetermined error occurred"

I just received this error on my vent after I was checking services in Windows 10.

Service that caused the error:
Capability Access Manager
Service Provides facilities for managing UWP apps access to app capabilities as well as checking an app's access to specific app capabilities.
(Make sure the above service is automatic if you have it.)

Found out that by switching it off it turns off the "privacy settings" for the microphone and various other items in the newest Windows 10 patch.

Look under "setting">"privacy">"microphone", make sure "Allow apps to access your microphone" is turned on to fix most microphone issues with the newest windows 10 patch.
That fixed it. Thank you!
LeeroyBro is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.