Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Server

Closed Thread
 
Thread Tools Display Modes
Old 01-08-2010, 01:05 PM   #1
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,339
Default Vent Server on Windows Server (variations)

I have installed the following versions of Windows Server and Ventrilo Server for testing. Ventrilo worked as expected with only a few rule changes in Windows Firewall.

Note: In all configurations only 1 NIC was enabled in the Operating Sytem.

Server 2008 x86 installed on an old Dell 4600, Intel P4 2.4GHz, 2GB

Server 2008 x64 installed on an HP Pavillion, AMD Athlon 64 X2 Dual Core 4600+, 4GB

Windows Home Server installed on an HP Pavillion, AMD Athlon 64 X2 Dual Core 4600+, 4GB

If you are having problems with any of these Operating Systems then please start a new thread explaining the issue.

Last edited by Prog-Rocker; 01-12-2010 at 11:21 AM.
Prog-Rocker is offline  
Old 01-08-2010, 01:05 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,339
Default Windows Server 2008 x86

Windows Server 2008 x86

Standard Full-Installation with all Updates
All settings in “Default” state

Quick Firewall test – Server Manager / link: Go to Windows Firewall / link: Windows Firewall Properties / Public Profile tab / set Firewall State = Off / apply

Ventrilo Client running on the same PC (configured using “Localhost” as the server name) should connect without any problems.
Ventrilo Client running on a different PC will need to have the following firewall rules added.

Windows Firewall / Inbound Rules / New Rule / Port / TCP – Specific Local Port = 3784 / Allow Connection / (all profiles selected) /

Windows Firewall / Inbound Rules / New Rule / Port / UDP – Specific Local Port = 3784 / Allow Connection / (all profiles selected) /

Last edited by Prog-Rocker; 01-08-2010 at 02:18 PM.
Prog-Rocker is offline  
Old 01-08-2010, 01:05 PM   #3
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,339
Default Windows Server 2008 x64

Windows Server 2008 x64

Standard Full-Installation with all Updates
All settings in “Default” state

Quick Firewall test – Server Manager / link: Go to Windows Firewall / link: Windows Firewall Properties / Public Profile tab / set Firewall State = Off / apply

Ventrilo Client running on the same PC (configured using “Localhost” as the server name) should connect without any problems.
Ventrilo Client running on a different PC will need to have the following firewall rules added.

Windows Firewall / Inbound Rules / New Rule / Port / TCP – Specific Local Port = 3784 / Allow Connection / (all profiles selected) /

Windows Firewall / Inbound Rules / New Rule / Port / UDP – Specific Local Port = 3784 / Allow Connection / (all profiles selected) /

Last edited by Prog-Rocker; 01-08-2010 at 02:18 PM.
Prog-Rocker is offline  
Old 01-08-2010, 01:07 PM   #4
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,339
Default Windows Home Server

Standard Full-Installation with all Updates
All settings in “Default” state

Upon starting the Ventrilo Server program the Windows Firewall will popup a message stating that “ventrilo_srv” has been blocked. There will be an option to “Unblock” the Ventrilo Server. Click on the “Unblock” button to allow network access.

Last edited by Prog-Rocker; 01-12-2010 at 10:51 AM.
Prog-Rocker is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.