Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Server

Closed Thread
 
Thread Tools Display Modes
Old 12-13-2007, 07:14 PM   #1
digiphreak
Junior Member
 
Join Date: Dec 2007
Posts: 1
Default How I fixed Server 3.0

Like many others I had difficulty after upgrading to server 3.0

I could connect internally on the LAN IP - but not on the WAN IP. External users were unable to connect to my server from outside my network. They only got the message MSG: Contacting Server.

I'm using a Netgear WGR614 router.

Port forwarding was set up - but apparently the old server used TCP only and version 3.0 uses UDP as well.

Problem - the WGR614 does not allow you to specify the protocol. TCP is apparently assumed with the exception of a few forwarding schemes that are built in.

Solution - Under the advanced menu - go to the WAN setup page. Check on "Default DMZ server" and set it to the LAN IP of your Vent server. This will default all traffic to that IP that isn't specifically forwarded elsewhere (including UDP on port 3784).

This fixed my problem.

If you aren't using a WGR614 but aren't able to specify UDP forwarding - look for a similar setting on your router.

If you can specify UDP - make sure you create 2 rules... 1 for UDP and 1 for TCP. My understanding is that some people have had trouble when setting a single line UDP \ TCP rule.

Hopefully this helps at least one person out there!

Good luck all.

digi

Edit: I should disclose that this does essentially put your server in a DMZ so only do this if you are willing to accept the security risks inherent in doing so.


Edit 2:

In the end I didn't want my server in the DMZ due to the security concerns, so I ended up replacing my router. This one is cheap and works beautifully. http://www.newegg.com/product/produc...82E16833127091

Last edited by digiphreak; 03-06-2008 at 05:38 PM.
digiphreak is offline  
Old 12-13-2007, 08:01 PM   #2
wadesworld
Senior Member
 
Join Date: Nov 2005
Posts: 2,934
Default

Good tip. Routers are often woefully short on the configuration options they should have.
wadesworld is offline  
Old 12-17-2007, 03:40 AM   #3
Magnoon
Junior Member
 
Join Date: Sep 2005
Posts: 4
Default

Setting DMZ can compromise your systems security.

Make sure you have atleast a firewall running at the server!
Magnoon is offline  
Old 12-19-2007, 11:36 PM   #4
JLinehan2004
Junior Member
 
Join Date: Dec 2007
Posts: 1
Default

Hey I'm having the same problem w/ connecting to v3.0.1. I get the "Msg: Contacting Server." My Router is a Linksys WRT54G. I am very computer illiterate. I'm guessing that I'm having the same problem as this guy, but I wasn't sure which "Advanced" option he is referring to. I'm really just asking for a possible brief step by step on fixing this problem. I run on Windows if that helps.
JLinehan2004 is offline  
Old 12-20-2007, 05:42 PM   #5
denelly
Junior Member
 
Join Date: Nov 2007
Posts: 6
Default

i have the same one as him. when i do that i put in my computers ip and i get disconnected from the internet
denelly is offline  
Old 01-01-2008, 07:57 AM   #6
darryle
Junior Member
 
Join Date: Nov 2007
Posts: 6
Default

This thread was VERY helpfull, thank you so much, fixed all my connection problems!!

UDP port map was the trick!
darryle is offline  
Old 01-24-2008, 12:34 PM   #7
90efhatch
Junior Member
 
Join Date: Jan 2008
Posts: 2
Default

Very good info thanks.
90efhatch is offline  
Old 03-15-2008, 06:40 AM   #8
kilikopele
Junior Member
 
Join Date: Mar 2008
Location: St Cloud, MN
Posts: 3
Thumbs up

Quote:
Originally Posted by digiphreak View Post
If you can specify UDP - make sure you create 2 rules... 1 for UDP and 1 for TCP. My understanding is that some people have had trouble when setting a single line UDP \ TCP rule.

Hopefully this helps at least one person out there!
AAARGH! (But in a good way.) So I read this post about 18 times, but apparently I'm an arrogant SOB who said my Linksys router properly handles the TCP/UDP BOTH setting. Gee, that COULDN'T be why I'm not connecting could it?

Now, here I am reading it at 4 in the morning and I decide to make separate rule lines for 3784TCP, 3784UDP, and 6100UDP. CONNECT. READY...

Thanks DigiFreak! You can count me as your one person. For others out there who are arrogant SOBs and can't figure out why people can't connect to you, split your TCP and UDP rules into different lines.
kilikopele is offline  
Old 03-15-2008, 05:28 PM   #9
wfisher
Junior Member
 
Join Date: Mar 2008
Posts: 4
Default Also Have Netgear Router

I am installing 3.0 server for the first time on my server. I have the same netgear router as the original poster on here.. I have done everything I can think of to get server to work, including

Port forwarding TCP 3784, UDP 3784, UDP 6100
Putting that machine in the DMZ as instructed above...


Still No dice. I have a static external IP through my ISP, so I know its not that problem and I have assigned the server running vent a static IP on my internal network (192.168.x.x).

I get the same"contacting server" message mentioned in the message from the company mentioned here: http://www.ventrilo.com/forums/showthread.php?t=23255

I would really like to get this working, if anyone has any ideas, please respond.

Thanks,
wfisher is offline  
Old 03-17-2008, 10:55 AM   #10
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,342
Default

Local Connection

If you’re connecting the client from a different PC than the server then configure the client to use one of the internal ipaddresses of the server. If you’re running the client on the same PC as the server then use 127.0.0.1 or “localhost” as the servername.


check your portforward setup with this:

http://ventrilo.com/status.php

put in your external ipaddress and 3784
Prog-Rocker is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 03:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.