Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 09-02-2016, 10:05 PM   #1
MrMarcus
Junior Member
 
Join Date: Sep 2016
Posts: 4
Default W10 Home XBOX 1 Controller

Having a strange issue, hope someone can help

I have a brand new install of W10 Home

I installed Ventrillo

Set Directsound on input and output

Use PTT with ~ as the key

Connect to server

Works no problem

Connect Xbox 360 controller and set an advanced binding using direct input. Set button 5 which is RB to be PTT. It works while I am in vent. If I remove focus from vent it stops working.

I have vent loaded in admin mode. If I hold the button down inside vent it transmits, if then click my desktop removing focus from vent it stops transmitting.

have tried reinstalling controller and ventrillo. I am stumped. Any ideas would be greatly appreciated.

Last edited by Prog-Rocker; 10-30-2016 at 09:20 PM.
MrMarcus is offline   Reply With Quote
Old 09-03-2016, 01:24 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,339
Default

in vent setup/voice tab, try unchecking 'use directinput to detect', enable 'discard hotkey', then re-check 'use directinput'
Prog-Rocker is offline   Reply With Quote
Old 09-03-2016, 03:10 PM   #3
MrMarcus
Junior Member
 
Join Date: Sep 2016
Posts: 4
Default

Yes, I tried that. I even reinstalled windows from scratch today for a different reason. Oddly enough same issue. I'm going to try a different controller later.
MrMarcus is offline   Reply With Quote
Old 09-05-2016, 08:48 PM   #4
MrMarcus
Junior Member
 
Join Date: Sep 2016
Posts: 4
Default

I was mistaken I was using an Xbox ONE controller. That is what wasn't working. I hooked up an older 360 pad and it works just fine now... go figure. Not an ideal solution, but acceptable. Sorry to see these forums are pretty dead, guess Vent isn't as popular as it used to be.
MrMarcus is offline   Reply With Quote
Old 09-05-2016, 11:01 PM   #5
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,339
Default

I have duplicated this with my xbox 1 pad. will work on finding a solution.

note: buttons not working as main ptt either

Last edited by Prog-Rocker; 09-05-2016 at 11:25 PM.
Prog-Rocker is offline   Reply With Quote
Old 09-06-2016, 12:24 PM   #6
MrMarcus
Junior Member
 
Join Date: Sep 2016
Posts: 4
Default

Quote:
Originally Posted by Prog-Rocker View Post
I have duplicated this with my xbox 1 pad. will work on finding a solution.

note: buttons not working as main ptt either
Yes, correct. It will work as either a main or an adv. binding while the vent window is in focus. If you have the trigger pulled in and pull vent out of focus it will disconnect. It also won't work out of focus regardless. A very confusing problem that makes no sense. Glad it's not just me!
MrMarcus is offline   Reply With Quote
Old 09-08-2016, 12:23 PM   #7
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,339
Default

looking at this as a possible cause:

http://arstechnica.com/gaming/2016/0...ess-right-now/


i might still have a pre-update win 10 i will test with when i get back it town.
Prog-Rocker is offline   Reply With Quote
Old 09-14-2016, 05:56 PM   #8
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,339
Default

update:

upon further testing we've discovered that xbox driver version 10.0.10586.0 seems to work fine as we tested on 2 different systems.

driver version 10.0.14393.0 does not work properly on my laptop. i do not know why the difference in versions as all 3 pc's get the auto updates.

can you post your driver version plz:

goto device manager > open xbox peripherals > rt-clik on xbox gaming device and select properties > goto driver tab > driver version

also tested on win7/8.1...both worked properly

------------------

did a search on 'xbox driver 10.0.10586.0' and a few posts on different forums suggested the 10.0.10586.0 version resolves some issues. i'm trying to find a credible download source for this version.

Last edited by Prog-Rocker; 09-15-2016 at 02:53 PM.
Prog-Rocker is offline   Reply With Quote
Old 09-30-2016, 12:08 PM   #9
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,339
Default

refer to this thread for more info and solution:

http://forum.ventrilo.com/showthread.php?t=3784497
Prog-Rocker is offline   Reply With Quote
Old 02-25-2017, 01:37 PM   #10
cBizzzz
Junior Member
 
Join Date: Feb 2017
Posts: 5
Default

FIX

https://youtu.be/76asVtL4gwg
cBizzzz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.