Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 11-26-2009, 08:05 PM   #1
Metfan1
Junior Member
 
Join Date: Nov 2009
Posts: 2
Default Music over Vent??

Was hoping there is someway to be able to play line level sound such as a playlist from Windows Media Player into a certain channel of vent so members can join that channel and listen while playing... is this possible at all?? Right now I just have a mic sitting infront of my tower speakers which doesnt sound all that great.

Thank you for any info, Cale.
Metfan1 is offline   Reply With Quote
Old 11-27-2009, 12:10 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,463
Default

it depends on if the audio device has mixing capabilities:

Setting up a DJ Connection

(Windows XP)

Here are some generic instructions. Your settings may vary depending on soundcard configurations, and drivers.

you will need 2 sound devices, either 2 soundcards, or, 1 soundcard and a usb headset.

configure vent to run multiple instances, one for music and one for regular talking.
rt-clik on the vent desktop icon > properties > add a -m to the end of the 'Target' line.

(ex: "C:\Program Files\Ventrilo\Ventrilo.exe" -m) the space before the -m is required

configure the music instance with a different login name so you can tell them apart when connected.
(note: if you ever need to make configuration changes, exit all copies, startup one, make the changes, then exit and restart all copies of vent)

in vent setup/voice tab, the music soundcard should be configured to 'use directsound' on both input/output devices and the device name should be that soundcard name (do not set it to a USB Headset name).

configure the hardware mixer section to the same sound device as set in the ‘Input Device’, mux=recording and line={‘stereo mix’, 'what-you-hear' or something similar}.

In vent setup/events tab, set all events to “Nothing”

set sensitivity=1 or 0 and uncheck PTT

on the main screen, check the 'mute sound' box at the bottom

note: if you don’t want to listen to the music coming back thru vent then on your talking client select the music client > rt-click > user > mute

(Windows Vista)

(Settings for onboard soundchip. Addin soundcards usually provide their own control-panel app)

configure vent to run multiple instances, one for music and one for regular talking.
rt-clik on the vent desktop icon / properties / add a -m to the end of the 'Target' line.

(ex: "C:\Program Files\Ventrilo\Ventrilo.exe" -m) the space before the -m is required

configure the music instance with a different login name so you can tell them apart when connected.
(note: if you ever need to make configuration changes, exit all copies, startup one, make the changes, then exit and restart all copies of vent)

goto Windows-control-panel / sound / Recording tab / rt-click in window / check ‘show disabled devices’ / rt-click on ‘Stereo Mix’ and select ‘properties’ / Levels tab / set volume level (50%) / Advanced tab / select ‘2 channel 44 Hz’ in pulldown window’ / click OK

select Playback tab / rt-click on ‘Speakers’ and select ‘properties’ / Levels tab / mute the microphone and any other jacks that are not in use (click on the little speaker icon next to each one)

reboot to make sure settings are in effect

in vent setup/voice tab, set both input/output devices to the device name of the soundcard (ex: Realtek…) and check the ‘Use Directsound’ boxes

in the hardware mixer section, set Mixer=Stereo Mix, mux=Master Volume, and line=Master Volume
(use the ‘line volume’ slider to adjust the microphone output volume)

set sensitivity=1 or 0 and uncheck PTT (setting sensitivity=1 will stop broadcasting during times of no outgoing signal, like in-between songs or if you pause/stop the music. It will also help flush the buffers)

In vent setup/events tab, set all events to “Nothing”

on the main screen, check the 'mute sound' box at the bottom

note: if you don’t want to listen to the music coming back thru vent then on your talking client select the music client > rt-click > user > mute
Prog-Rocker is offline   Reply With Quote
Old 11-27-2009, 12:46 PM   #3
Metfan1
Junior Member
 
Join Date: Nov 2009
Posts: 2
Default Thanks

Awesome Im going to play around with this... ty for the help
Metfan1 is offline   Reply With Quote
Old 04-28-2010, 02:56 PM   #4
brambopaus
Junior Member
 
Join Date: Apr 2010
Posts: 6
Default

ok i can all get this.. but ,
my sound (Via itunes) still isnt playing on the server,
i also dont know how to change the playback for the music "user"
because if i change the playback of the music "user", the out/input for myself also changes...
how to get it working with still being able to talk and hear through headset
but play music with the other user on the same pc ?
brambopaus is offline   Reply With Quote
Old 04-28-2010, 04:33 PM   #5
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,463
Default

if you need to make setup changes in the client then only 1 instance of the client can be running in order to make changes.
Prog-Rocker is offline   Reply With Quote
Old 04-29-2010, 02:25 PM   #6
brambopaus
Junior Member
 
Join Date: Apr 2010
Posts: 6
Default

Quote:
Originally Posted by Prog-Rocker View Post
if you need to make setup changes in the client then only 1 instance of the client can be running in order to make changes.
ok i get that,
but still cant play the music,..
how does it even play the music ?
select integration and then itunes for example...
and then we can read the song playing but dont hear it...
anyway to get more help then "the standard how to make musis channel post" ?
brambopaus is offline   Reply With Quote
Old 04-29-2010, 02:49 PM   #7
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,463
Default

can you post pic of both client setups plz.

what OS and audio device are you using?
Prog-Rocker is offline   Reply With Quote
Old 04-29-2010, 03:14 PM   #8
brambopaus
Junior Member
 
Join Date: Apr 2010
Posts: 6
Default


dont know what OS means..
audio device, i guess u mean itunes,.. or the mediamixer from my laptop
brambopaus is offline   Reply With Quote
Old 04-29-2010, 03:15 PM   #9
brambopaus
Junior Member
 
Join Date: Apr 2010
Posts: 6
Default

and as i can see now, the uploading doesnt work from pictures..
these will work i hope :
http://www.**********.com/?d=MCZ6K0D3
this is the user which talks (me)
http://www.**********.com/?d=6P6XI4WU
this is the user for the music
and it helps u dont support **********, so i cant show the pictures
or u can copy the link and type mega upload in place of the ******
sry for many re-editings

Last edited by brambopaus; 04-29-2010 at 03:18 PM.
brambopaus is offline   Reply With Quote
Old 04-29-2010, 04:34 PM   #10
brambopaus
Junior Member
 
Join Date: Apr 2010
Posts: 6
Default

Quote:
Originally Posted by Prog-Rocker View Post
can you post pic of both client setups plz.

what OS and audio device are you using?
it seams like im just not able to get any good pics in here... and i dont know what OS means, and also dont really know what u mean with the audio device... i think the sound card or something
brambopaus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.