Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 06-22-2017, 09:07 AM   #1
pdxgem725
Junior Member
 
Join Date: Jun 2017
Posts: 2
Default Vent taking priority?

I picked up a bluetooth headset and am able to hear WoW and listen to music simultaneously, but when I connect to Vent, the music and WoW go silent and I can only hear Vent chat. If I use my PC speakers and mic, I can do all three at the same time. I've contacted both the headset manufacturer and HP. Both were unable to help, saying that it's probably properties in Vent that force it to take precedence over any other software.

Is this the issue? If so, is there a way to remedy it? If not, are there any suggestions?

Thanks!
pdxgem725 is offline   Reply With Quote
Old 06-22-2017, 01:43 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,331
Default

what make/model BT headset are you using? does it have the dual BT connectivity option?

BT is limited to only 2 channels, either stereo audio, or mono audio w/mic. when vent is active the BT driver should switch to the mono/mic mode.

first check the vent setup/voice-binds-speech tabs, make sure the output/input are set to the BT device.

next, check the windows audio properties to make sure the other apps are not muted. rt-clik on the speaker icon the the system tray, select 'volume mixer' , select the BT under the device column. check for muted apps (red circle on speaker icons below volume slider). also check volume slider levels on apps

is the bt set as the default device in windows?

what version of window are you running?

Last edited by Prog-Rocker; 06-22-2017 at 02:58 PM.
Prog-Rocker is offline   Reply With Quote
Old 06-22-2017, 02:45 PM   #3
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,331
Default

update:

just tried this with win10 and old BT headset. at first i did experience the same problem while using winamp and overwatch with vent. it seems the bt driver is not switching properly between stereo-headphone and mono-headset w/mic.

in order to get all the audio i had to manually switch the default device in win-control panel-sounds.

my device has 2 options, headphones (audio only) or headset (mono/mic). i had to set the default device to the headset to get all the audio plus mic availability. once i set it there then all audio came thru the headset. i would suggest setting this first and then start the other apps.

when the mic is no longer needed then you can manually switch back to the stereo device setting.

Last edited by Prog-Rocker; 06-22-2017 at 02:59 PM.
Prog-Rocker is offline   Reply With Quote
Old 06-23-2017, 10:30 AM   #4
pdxgem725
Junior Member
 
Join Date: Jun 2017
Posts: 2
Default

Thanks for the response! I'm using Skullcandy Hesh 2 wireless headphones. I followed the steps you provided and everything was working together, but the audio was very poor quality and choppy (assuming because it's only mono). I've changed some of my system defaults and am using my PC mic rather than the headset mic and am using the headphones for music, vent, and in game audio. I seem to be getting all audio in stereo, so all is right in the world

Last edited by pdxgem725; 06-23-2017 at 11:06 AM.
pdxgem725 is offline   Reply With Quote
Old 06-29-2017, 07:45 AM   #5
mariad
Member
 
Join Date: Mar 2017
Posts: 31
Default

How much did you pay for the Skullcandy Hesh 2?
mariad is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 06:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.