Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Reply
 
Thread Tools Display Modes
Old 05-20-2007, 12:30 PM   #1
kythian
Junior Member
 
Join Date: May 2007
Posts: 4
Default FIXED!!! 'Sound input device has been closed.'

For a while now I have been getting a particular error that seems to be recurring with many Vent users for a long time. I have searched high and low for a solution and have never found a suitable fix... until now.

The problem has been that while playing a game such as BF2, Counter-Strike Source and World of Warcraft, that the following error message will crop up:

Quote:
Sound input device has been closed.
It was sending data faster then it should be.
Try enabling the 'Use DirectSound for input device' option.
(Please note, the typo "faster than is should be" is in the error message.)

So, the fix that I have discovered is disturbingly simple. Enable the 'Use DirectSound for input device' option. BUT... I also had to enable 'Use DirectSound for output device' option as well... IN THREE DIFERENT LOCATIONS!!!!

There is one box under the VOICE tab, one under the BINDS tab, and the third under the SPEECH tab. Enable all three boxes!! This seems to have fixed the issue for me!

Good luck to everyone out there that has been having this problem! I'm still crossing my fingers hoping that my testing will continue to show that this is the proper solution.
kythian is offline   Reply With Quote
Old 05-26-2007, 07:24 PM   #2
kythian
Junior Member
 
Join Date: May 2007
Posts: 4
Default

After further testing for about a week, it appears that the above fix has worked.

I hope this helps everyone!

Cheers!
kythian is offline   Reply With Quote
Old 07-31-2007, 07:36 AM   #3
Markt
Junior Member
 
Join Date: Jul 2007
Posts: 2
Default

Thanks for the fix
Markt is offline   Reply With Quote
Old 07-31-2007, 05:49 PM   #4
simballic
Junior Member
 
Join Date: Jul 2007
Posts: 13
Default

I get this error daily and have always had all of these options checked. It is not a fix for me; however I am also having the problem of my ventrilo crashing about 5 times per 4hours I use it so... I'm hoping to find a solution to that in my post below.
simballic is offline   Reply With Quote
Old 08-09-2007, 03:22 PM   #5
ThorsenFFF
Junior Member
 
Join Date: Aug 2007
Posts: 2
Default

Tried your suggestion, but it didnt work at all! Anyone else got a bright idea?
ThorsenFFF is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.