Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Server

Reply
 
Thread Tools Display Modes
Old 03-14-2010, 09:57 PM   #1
larri
Junior Member
 
Join Date: Jan 2010
Posts: 9
Default Can someone help me test my server?

Hi... just wondering whether there is anybody around who could do a test for/with me (March 14/15).

My Ventrilo server is on a Mac iBookG4. Using Ventrilo client, i can connect to the server via the internal (LAN) IP address, and according to the status page, it is accessible from the outside as well (the status page also shows additional user info at the bottom when I am locally connected):

Voice Codec Speex
Voice Format 32 KHz, 16 bit, 5 Qlty
Platform Darwin-powerpc
Version 3.0.3
Channel Count 0
Client Count 1

However, a friend who tried to connect to my server got only as far as the "Contacting server" message and nothing showed up in the log at my end. Since she successfully connected to some of the public test servers that are out there, I would like to confirm whether my server works properly.

I would be very grateful if someone could try to connect to my server (and let me know if the connection is not successful). My IP address is 58.94.212.16, the port is the standard port, 3784, the password is "testx", and the server name is "aloha kaakou".

Thanks!
Larry
larri is offline   Reply With Quote
Old 03-15-2010, 05:42 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,457
Default

status page and server browser both see it but i couldn't telnet to it so something is blocking the 3784 TCP connection

make sure you're connecting locally as follows:

For PC’s connecting on the same LAN as the server:
If you’re connecting the client from a different PC than the server then configure the client to use one of the internal ipaddresses of the server for the servername.

If you’re running the client on the same PC as the server then use 127.0.0.1 or “localhost” as the servername.


if you're connecting using the external ipaddress then it could cause problems. (which i've seen from other users)

the problem is probably with the router portforwarding since i see you connected

Last edited by Prog-Rocker; 03-15-2010 at 05:44 PM.
Prog-Rocker is offline   Reply With Quote
Old 03-16-2010, 01:16 AM   #3
larri
Junior Member
 
Join Date: Jan 2010
Posts: 9
Default

Quote:
Originally Posted by Prog-Rocker View Post
status page and server browser both see it but i couldn't telnet to it so something is blocking the 3784 TCP connection
[...]
the problem is probably with the router portforwarding since i see you connected
Thank you very much for checking this out!

I have now changed the network configuration here so that the iBook running the server is no longer part of a subnet (there are several separate subnets in the building, all connected via secondary routers). It is now directly connected to the main router (the router that connects the building with the outside world). After adjusting the firewall and port forward settings of that router to account for the different IP address of the server, I checked, via the status page, that the server is accessible again.

I would be most grateful if you could do another test now:
IP address 58.94.67.1
port 3784
password "testx"
(the server name is "aloha kaakou")

Thanks!

Larry

Last edited by larri; 03-16-2010 at 01:19 AM.
larri is offline   Reply With Quote
Old 03-16-2010, 01:41 AM   #4
Fonzie311
Junior Member
 
Join Date: Mar 2010
Posts: 20
Default

Quote:
Originally Posted by larri View Post
Thank you very much for checking this out!

I have now changed the network configuration here so that the iBook running the server is no longer part of a subnet (there are several separate subnets in the building, all connected via secondary routers). It is now directly connected to the main router (the router that connects the building with the outside world). After adjusting the firewall and port forward settings of that router to account for the different IP address of the server, I checked, via the status page, that the server is accessible again.

I would be most grateful if you could do another test now:
IP address 58.94.67.1
port 3784
password "testx"
(the server name is "aloha kaakou")

Thanks!

Larry
it up
Fonzie311 is offline   Reply With Quote
Old 03-17-2010, 02:26 AM   #5
larri
Junior Member
 
Join Date: Jan 2010
Posts: 9
Default

Quote:
Originally Posted by Fonzie311 View Post
it up
Hi, looks like something got snipped...
Did you want to tell me it doesn't work?

Anyway, one problem has been found and remedied: the iBook's firewall was turned on (and not configured for Ventrilo) - a situation that is hard to suspect if a status check, via the Ventrilo website, tells you that your server is ready.

Larry

Last edited by larri; 03-17-2010 at 10:26 PM.
larri is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 08:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.