Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Windows Client

Closed Thread
 
Thread Tools Display Modes
Old 08-27-2006, 10:10 PM   #1
isprog
Junior Member
 
Join Date: Aug 2006
Posts: 4
Thumbs up Possible Solution to Windows Client Ventrilo Audio Cutting Out

Hi.
I have been plagued on a couple of my PC's with the Windows Client of Ventrilo cutting out the speech and then stopping. Disconnecting and then reconnecting would fix the problem for a few secs and then no audio. I wanted to use Ventrilo with WOW.

This would happen on my main PC with Creative PCI Live!, and I tried the Asus AC'97 onboard sound, a pair of USB headphones and a LogiTech Premium USB Headset - all the same problem !!! It also happened on my Dell Precision M60 laptop. Not running WOW made NO DIFFERENCE. I tried ALL the various setup options, DirectSound, No DirectSound, Mic enabled/disabled, High/Normal piority, etc - no difference !!!

As I was trying to connect to a Ventrilo server running Speex I trieds both the normal WIndows client and the beta version - still no success. I even tried running WOW on my main PC and use my laptop to connect to the Ventrilo server - still no success !!! The fact I tried various sound devices, two separate machines implied that it had to be something common. I had even tried to use the router to Prioritise Ventrilo traffic - still no success.

What made matters worst is that my son's crappy PC on our home network could hear quite reasonably. AND yes, I have tried it without many network devices (just my main PC and the router) - with no difference. Our home network comprises of 2 PC's, an occassional wireless laptop and a Printer server.

Then after a lot of Googling, I discovered that EITHER MODIFYING or DELETING the Windows XP PROFESSIONAL (Home does not have this feature) local network protocol for QOS Scheduling made a singificant improvement !!!

The QOS Scheduler, from my searching, is used only on the internal network and not over a router (Thus the Internet).

I deleted the QOS Scheduler. Others changed it behaviour using the group policy editor. WHAT A DIFFERENCE !!!

It probably won't fix all ill's, but it might help some. Hope this helps.

Last edited by isprog; 08-27-2006 at 10:14 PM.
isprog is offline  
Old 08-27-2006, 10:29 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,340
Default

Good Observation and Troubleshooting.

I always turn that off when installing windows from scratch.
Prog-Rocker is offline  
Old 08-28-2006, 07:18 PM   #3
Snorrii
Junior Member
 
Join Date: Aug 2006
Posts: 1
Default More of the same

I have the exact same problem. Frankly, I haven't done as much troubleshooting as isprog has and was hoping this was a quick fix. Sadly, my computer runs XP Home. Is there an alternative to this?

Any advice would be appreciated.
Snorrii is offline  
Old 08-29-2006, 01:22 PM   #4
aaronxquixote
Junior Member
 
Join Date: Aug 2006
Posts: 1
Default

I actually just got a new laptop not to long ago, and i've been having this same problem. For the first few minutes on vent my voice projects fine - then after that everyone tells me I start cutting out pretty frequently.

Is this a sound card issue? Thats what I figured it was, since I just have an "average" Dell customized laptop. But I also have xpHome...so does anyone have any ideas / fixes for us?
aaronxquixote is offline  
Old 08-30-2006, 10:37 PM   #5
isprog
Junior Member
 
Join Date: Aug 2006
Posts: 4
Default

Okay, I have always avoided Windows XP Home so I was not sure over it's networking setup, but some researching indicates that you can still disable the QoS Packet Scheduler service.

To do so:
Click START
Open Network Connections
On the "Local Area Connection" icon, right click and click PROPERTIES

In the listed clients, services & protocols, the QoS Packet Scheduler, if used, should be shown in the list. Hightlight it and select remove. You will be warned that doing this as it affects all network services. Confirm it's removal. All done I hope ! If it is not shown check to see if it is running (refer to services.msc at end of this post)

An alternative method, which is where I might have been mislead, was that you can use the group policy editor (Windows XP Pro ONLY) and change the behaviour of the QoS packet scheduler, but like I said in my original post, only applies to Windows XP Pro.

I also discovered a post for Windows XP Home and the removal of the QoS Packet Scheduler.
To do so:
Click START
Click RUN
Type: services.msc
Find the QOS service, and change it to disabled.

I HAVE NOT PROVEN THIS. I would only use if you could not delete the service.

Hope this helps.
isprog is offline  
Old 09-03-2006, 11:11 PM   #6
Silentshadow
Junior Member
 
Join Date: Aug 2006
Posts: 7
Default Same Problem

I Also have your exact same problem, but sadly deleteing QoS didnt work :/
OS: Windows XP, Media Center
Audio: No idea..
headphone: Logitech USB Headphones
Game playing: World Of Warcraft(WoW)

Ive had this problem for multiple months now, and iam extremly disapointed in the lack of problem solving that Ventrilo has done. Currently my Vent sever i log on to is running at GSM 6.10 44KHz, 16 bit, Ive tried alternating Outbound/Inbounds Directsound and what not, nothing has worked.. I tried deleteing QoS, but still no sucess, ive tried re installing ventrilo about 4 times, downloaded Beta, still nothing.. I can't seem to find the solution.. Ive looked over al lthe fourms and no ones even mentioned this except you. But mine has to be alterd or messed up becuase your solotion didnt fix it. I'd be extremly shocked if you could fix my problem.. Ive talked to Computer Genius People and still no solution. Anyways id really like a response.. and somehow a way to fix my problem, Thanks
Silentshadow is offline  
Old 09-03-2006, 11:16 PM   #7
Silentshadow
Junior Member
 
Join Date: Aug 2006
Posts: 7
Default

I Looked over Services.msc and i found " QoS RSVP " i dont know what it is.. but it might have to do somthing about my problem.
Silentshadow is offline  
Old 09-08-2006, 03:38 PM   #8
mekorn2000
Junior Member
 
Join Date: Sep 2006
Posts: 2
Default

this did not work for me either...it sounds like I have the same issue as Silentshadow

I am able to talk in vent without problems until I log on to a server through "steam" after I can still hear everyone else but I cannot speak to them.
I hope to get some help...Please
mekorn2000 is offline  
Old 09-08-2006, 11:10 PM   #9
isprog
Junior Member
 
Join Date: Aug 2006
Posts: 4
Default

Quote:
Originally Posted by Silentshadow
I Looked over Services.msc and i found " QoS RSVP " i dont know what it is.. but it might have to do somthing about my problem.
Sorry, I infrequently visit the Ventrilo forums.
But YES that is the service u should try and disable. You be be able to select it and then right click for PROPERTIES. From there, if it is already running, STOP it. Then you can either select DISABLE (I think) or MANUAL.

MANUAL meansthat if you wish to have it running, you have to use services.msc and select it, then START it.

Maybe this will help ?
isprog is offline  
Old 09-12-2006, 10:08 PM   #10
Silentshadow
Junior Member
 
Join Date: Aug 2006
Posts: 7
Default Lag

Sadly, no it didnt work. I even tried deleteing it up on my other comp on the same network(hardwired) and still didnt work :/
Silentshadow is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.