Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Macintosh Client

Reply
 
Thread Tools Display Modes
Old 06-11-2009, 08:28 PM   #1
realplat
Junior Member
 
Join Date: Jun 2009
Posts: 6
Default Vent crashes when USB headset selected for input

I am currently running vent (3.04) on my mac pro (info below). If I have any USB headset selected for input, vent immediately crashes upon connection to a server. If I do not connect to a server vent will stay open indefinably. If I change the input to anything else, vent works fine, but obviously I can not speak.

I am running version 3.01 on my mac book pro and it works fine. I tried to downgrade on the mac pro, and this didn't help.

Any ideas would be great...Thanks
Model Name: Mac Pro
Model Identifier: MacPro1,1
Processor Name: Dual-Core Intel Xeon
Processor Speed: 2.66 GHz
Number Of Processors: 2
Total Number Of Cores: 4
L2 Cache (per processor): 4 MB
Memory: 5 GB
Bus Speed: 1.33 GHz
Boot ROM Version: MP11.005C.B08
SMC Version (system): 1.7f10
realplat is offline   Reply With Quote
Old 06-11-2009, 09:19 PM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,340
Default

any other usb devices plugged in?

is the headset plugged directly into one of the usb ports? (not into any usb hub device)
Prog-Rocker is offline   Reply With Quote
Old 06-12-2009, 08:01 PM   #3
realplat
Junior Member
 
Join Date: Jun 2009
Posts: 6
Default

There are a few other usb devices (keyboard, mouse, external HDs etc) but no other mics or headsets.

Directly into a usb port, and I've tried different ports and a second headset plugged into different ports. I've tried to isolate it as best as possible.
realplat is offline   Reply With Quote
Old 06-23-2009, 10:40 PM   #4
Amadtaz
Junior Member
 
Join Date: Jun 2009
Posts: 4
Default

I have the same issue.

My microphone is with a "Logitech ClearChat Comfort USB". The box says it works with Skype, Yahoo!, Windows Live and AIM but Vent doesn't seem to like it at all. I have been using Vent for about a month now with only the occasional crash (at the worst times of course) and to make things a little nicer, I bought this headphone/microphone combo thing.

I would normally RTFM, but there is no way that I'm missing something besides an update from Ventrilo to fix this issue.

I have a MacBook Pro with a Core2Duo running 10.5.7

Help me Ventrilo, you're my only hope!
Amadtaz is offline   Reply With Quote
Old 06-24-2009, 01:30 AM   #5
smtips
Junior Member
 
Join Date: Jun 2009
Posts: 8
Default

Check your Audio Midi setup. Check your input in the sound control panel before connecting to a server with vent.
smtips is offline   Reply With Quote
Old 06-29-2009, 11:21 PM   #6
realplat
Junior Member
 
Join Date: Jun 2009
Posts: 6
Default

Quote:
Originally Posted by smtips View Post
Check your Audio Midi setup. Check your input in the sound control panel before connecting to a server with vent.
Not sure what I should check but, the mic works, just makes vent crash...
realplat is offline   Reply With Quote
Old 07-03-2009, 05:14 PM   #7
realplat
Junior Member
 
Join Date: Jun 2009
Posts: 6
Default

I just wanted to add that this problem still happens even with an imic connected. Apparently this must have something to do with USB being used with vent.
realplat is offline   Reply With Quote
Old 07-03-2009, 05:25 PM   #8
realplat
Junior Member
 
Join Date: Jun 2009
Posts: 6
Default

Not sure if this can help anyone help me but here is the problem report that the OS generated to send to apple. Left some of it off as its really long...


Process: Ventrilo [5288]
Path: /Applications/Ventrilo.app/Contents/MacOS/Ventrilo
Identifier: com.ventrilo.Ventrilo
Version: 3.0.4 (3.0.1)
Code Type: X86 (Native)
Parent Process: launchd [113]

Interval Since Last Report: 1069730 sec
Crashes Since Last Report: 15
Per-App Interval Since Last Report: 90434 sec
Per-App Crashes Since Last Report: 15

Date/Time: 2009-07-03 14:23:14.563 -0700
OS Version: Mac OS X 10.5.7 (9J61)
Report Version: 6
Anonymous UUID: 527186A5-422E-4F7D-9C9B-51181829C546

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread: 11

Thread 0:
0 libSystem.B.dylib 0x900043a6 mach_wait_until + 10
1 ...ple.CoreServices.CarbonCore 0x920dc917 MPDelayUntil + 39
2 ...ple.CoreServices.CarbonCore 0x920dc7ab Delay + 104
3 com.ventrilo.Ventrilo 0x000721f9 0x1000 + 463353
4 com.ventrilo.Ventrilo 0x0003a468 0x1000 + 234600
5 com.ventrilo.Ventrilo 0x00031e5a 0x1000 + 200282
6 com.ventrilo.Ventrilo 0x000302a1 0x1000 + 193185
7 com.ventrilo.Ventrilo 0x0001883b 0x1000 + 96315
8 com.ventrilo.Ventrilo 0x0001ecb4 0x1000 + 122036
9 com.ventrilo.Ventrilo 0x0002509b 0x1000 + 147611
10 com.apple.HIToolbox 0x914a211d DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1181
11 com.apple.HIToolbox 0x914a155b SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
12 com.apple.HIToolbox 0x914bdeac SendEventToEventTarget + 52
13 com.apple.HIToolbox 0x914f21c7 SendHICommandEvent(unsigned long, HICommand const*, unsigned long, unsigned long, unsigned char, OpaqueEventTargetRef*, OpaqueEventTargetRef*, OpaqueEventRef**) + 411
14 com.apple.HIToolbox 0x9156180e SendHICommandToTarget + 58
15 com.apple.HIToolbox 0x915d8440 SendControlCommand(HIView*, unsigned long, unsigned long) + 64
16 com.apple.HIToolbox 0x915178f2 HIView::NotifyControlHit(OpaqueEventRef*, short, unsigned long) + 122
17 com.apple.HIToolbox 0x915817d8 HIView::ClickInternal(CGPoint const&, unsigned long, void (*)(OpaqueControlRef*, short), OpaqueEventRef*, bool) + 254
18 com.apple.HIToolbox 0x9156dfb6 HIView::ClickSelf(OpaqueEventRef*) + 370
19 com.apple.HIToolbox 0x914b0751 HIView::EventHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 2391
20 com.apple.HIToolbox 0x914a211d DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1181
21 com.apple.HIToolbox 0x914a155b SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
22 com.apple.HIToolbox 0x914bdeac SendEventToEventTarget + 52
23 com.apple.HIToolbox 0x9156b5f7 HIView::Click(OpaqueEventRef*) + 329
24 com.apple.HIToolbox 0x9156b459 HandleClickAsHIView(OpaqueWindowPtr*, OpaqueEventRef*) + 151
25 com.apple.HIToolbox 0x9156ade9 HandleWindowClick(OpaqueWindowPtr*, Point, short, unsigned long, OpaqueEventRef*) + 505
26 com.apple.HIToolbox 0x9156abdb HandleMouseEvent(OpaqueEventHandlerCallRef*, OpaqueEventRef*) + 791
27 com.apple.HIToolbox 0x915265e2 StandardWindowEventHandler(OpaqueEventHandlerCallR ef*, OpaqueEventRef*, void*) + 96
28 com.apple.HIToolbox 0x914a211d DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1181
29 com.apple.HIToolbox 0x914a155b SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
30 com.apple.HIToolbox 0x914bdeac SendEventToEventTarget + 52
31 com.apple.HIToolbox 0x914d0088 ToolboxEventDispatcherHandler(OpaqueEventHandlerCa llRef*, OpaqueEventRef*, void*) + 1208
32 com.apple.HIToolbox 0x914a24d6 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2134
33 com.apple.HIToolbox 0x914a155b SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
34 com.apple.HIToolbox 0x914bdeac SendEventToEventTarget + 52
35 com.apple.HIToolbox 0x9152aa4c ToolboxEventDispatcher + 86
36 com.apple.HIToolbox 0x915272a2 RunApplicationEventLoop + 222
37 com.ventrilo.Ventrilo 0x0000b8f3 0x1000 + 43251
38 com.ventrilo.Ventrilo 0x00007e2e 0x1000 + 28206
39 com.ventrilo.Ventrilo 0x00007d55 0x1000 + 27989
realplat is offline   Reply With Quote
Old 04-30-2010, 11:40 AM   #9
brodicius
Junior Member
 
Join Date: Apr 2010
Posts: 6
Default

Yeah, I've got the same issue.

Really long message too. However, the chunk around

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread: 10

is the same.

Anyone have any clues as to what we need to do about this?
brodicius is offline   Reply With Quote
Old 06-07-2010, 04:24 AM   #10
brodicius
Junior Member
 
Join Date: Apr 2010
Posts: 6
Default

No one has any news?

People have had this issue for a year now, you'd think someone might have noticed.
brodicius is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 12:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.