Ventrilo Tech Support  

Go Back   Ventrilo Tech Support > Main Category > Macintosh Client

Reply
 
Thread Tools Display Modes
Old 06-08-2009, 05:43 AM   #1
TechnoMulen
Junior Member
 
Join Date: May 2009
Posts: 2
Default Mac users not able to connect.

hi i have no clue about mac user and how they setup their computers for my vent server
---------------------------------
they get this error
" quote "Failed to get encoder for secified Codec. This client platform currently supports only the Speex codec. The server and/or channel is configured to use the 'GSM 6.10' codec'

It means that your guild's Ventrilo server is not set to use the Speex codec.
You will need to approach your guild leaders about changing the settings in the main Ventrilo account. This may need to be changed in both the global settings and in the individual channel settings."
------------------------------------------------------------
we tried using a guide we found .... written below:
Getting your Mac ready
.---------------------------
1. Open your Mac's System Preferences
2. Select the Universal Access option.
3. At the bottom of the Universal Access window you will see a check box labled Enable Access for Assistive Devices. Make sure that option is selected.
4. Close the system preferences window and restart your computer for the change to take effect.

Download the Ventrilo Client Software.

1. Click Here to go to the Ventrilo downloads page.
2. Select the appropriate software for your machine and download it.
3. Run the installer.


Setting up Ventrilo

1. Start up the Ventrilo program
1. Click on the black arrow next to the User Name drop down window
2. Click on the New button and enter your user information.
3. Click OK to save the information
2. Click on the black arrow next to the Server drop down window.
1. Enter the IP address that your guild has provided for you.
2. Enter the Port number your guild has provided for you.
3. Enter the Password your guild has provided for you.
4. Click OK to save the information.
3. Click on the black arrow next to the Bindings drop down window
1. Click on the New button in the Setup Bindings Window
2. Name your new Binding settings. I called it Push To Talk
3. Click on the Add button in the lower left hand corner of the Setup Bindings window.
4. Push the button you want to be your Push to Talk Button in game and write it down, you will need this info later.
5. Verify that the PTT Advanced option is selected in the function drop down list.
6. Click OK to save the options.
7. A new window pops up called Edit PTT Advanced. Select Current channel from the Transmit Style drop down window.
8. Click OK to save your settings.
4. Click on the Setup button on the right hand side of the main Ventrilo window.
1. Verify that outgoing voice communications and Use Push-To-Talk (PTT Mode) are both enabled.
2. Select your PTT Hotkey in the Hotkey window. It is the same that you set the binding for earlier.
3. Check the Sound Output and Sound Input windows to be certain your headset is selected.
4. Click OK to save your settings.
5. Push the connect button to connect to the Ventrilo server and see if you can talk to your guildies.

Setting up in game

1. Start up World of Warcraft
2. Press Esc. to bring up the Options window
3. Select Sound & Voice from the Options window
1. Select the Voice tab at the bottom of the new window
2. Make sure that Push To Talk is selected under the Voice Chat Mode drop down window.
3. Beneith the PTT selection enter the key on your keypad you want to activate your mic. It should be the same that you entered earlier in this set up process.
4. Make sure your headset is selected in the Microphone and Speakers drop down windows.
5. Click OK to save your settings.


Test it out. Push your mic hotkey and see if your guildies can hear you.

Common Errors

If you can talk to your guildies when you are in the Ventrilo program itself, but NOT when in game go back to the Getting Your Mac Ready section and make sure you have enabled assistive devices.

If you get the following message:
Failed to get encoder for secified Codec. This client platform currently supports only the Speex codec. The server and/or channel is configured to use the 'GSM 6.10' codec'

It means that your guild's Ventrilo server is not set to use the Speex codec.
You will need to approach your guild leaders about changing the settings in the main Ventrilo account. This may need to be changed in both the global settings and in the individual channel settings.
--------------------------------------------------

ps im using GSM 44khz codex
TechnoMulen is offline   Reply With Quote
Old 06-08-2009, 11:00 AM   #2
Prog-Rocker
just tryin to help
 
Join Date: Jul 2006
Location: Local Space/Time Continuum
Posts: 23,340
Default

actually it's very simple,

the server needs to be configured to use the speex codec or if the mac users all connect to the same channel then that channel can be configured just for speex. (pro version)

to change the server, access your hosters c-panel for the server and change to speex. (suggest Speex (16 KHz, 16 bit, 9 Qlty) 4344 bytes/sec)
then restart the server.

Apple does not include the GSM codec due to Microsoft owning the license.

IMHO, I prefer Speex for sound quality of both voice and music.

if you do switch codec, recommend you inform all users to reset the amplifiers=0 in vent setup.
Prog-Rocker is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -5. The time now is 10:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.