View Single Post
Old 11-06-2005, 02:27 AM   #1
Eljefe
Junior Member
 
Join Date: Aug 2005
Posts: 3
Unhappy Invalid Input on PTT results in no mic function.

I have been reading the forums for days and I am at my wits end.

I am running on a 2ghz G5 iMac w/ 1.5gb ram.

I have virtual pc with windows 2000 professional and am attempting to use it to run ventrilo. Those I wish to communicate with are not going to change the codex to Speex for me, so I am still working on getting this to function with virtual pc and windows 2000 prof.

I am logged in to vent, I can hear everyone just fine, but when I use my push to talk button several things go wrong.

I get the noise that windows makes when you have an invalid input, except it gets about 1/2 way through transmitting the sound and repeats itself like a broken record so long as I hold the key down. This is the most annoying sound on earth imo.

My speaker icon next to my name turns green when I push my PTT, but none can hear me speak, this could be for several reasons which I have yet to narrow but it is my main problem -- if I could speak and have it work I would deal with anything else.

In my Setup tab within Ventrilo, I have the Use Push-To-Talk Hotkey selected and the Use DirectInput to detect Hotkey selected. For my Output and Input devices I have the Use DirectSound box checked.

Under my Hardware input mixer section, it is selected as (None), but I can select Sound Blaster 16, but when I do that I get an error message that reads:

"InputFindVolFader failed (-1) for non-Mux based mixer."

I cannot select anything other than "Recording Control" for the Mux, and "MIDI" for the Line. There are no other options, and certainly no "microphone" option for the line as I have read about in the forums.

Any way I run it, the microphone does not seem to work. I have adjusted my amplifiers to all differnt levels for my out bound. I have made sure that my microphone is not muted in the control panel/ of windows, and that an alternate microphone other than the built in one for my iMac is selected in the Macintosh system preferences. All volume levels have been tested over vent to no avail.

When I use the built in functions to monitor and test within Ventrilo, I get nothing in the test other than the same error noise I hear when I select my PTT key. When I run the monitor function, it seems to pick up my microphone just fine (meaning the digit changes from 1-9). However, when I speak into the microphone and have the system preferences/sound/input section open for the macintosh it does not register any bars, but when I select the built in microphone it seems to register input just fine.

I am not using a USB headset, rather I am using a regular two pronged headset. I am going to go purchase a USB headset tomorrow and see if I can get it to recognize on my mac.

My final problem is, I cannot get my PTT to recognize when I am not in the virtual PC window. I run WoW on my Mac and wish to run Vent on windows via virtual PC and I would hope that somehow I can get it to recognize my PTT key while I am in the Mac OS running my WoW.

I will post again tomorrow once I have my new headset and tested again, any suggestions would be greatly appreciated.

Thank you for your time.

Mostreed
Eljefe is offline   Reply With Quote