View Single Post
Old 08-05-2011, 03:33 PM   #3
Jaycyn
Senior Member
 
Join Date: Mar 2009
Location: Florida
Posts: 313
Default

That is excellent news! Thank you for persisting.

I did spot a post Apple's discussion forums that lends some insight into the issue.

Quoted from that thread

--------
(Apple) Engineering has determined that this issue originates with a 3rd party.

Why it is not a common issue before Mac OS X 10.5.7
On Mac OS X 10.5.6 & prior, the USB audio driver publishes 2 audio engines, one for input stream and another for output stream. Applications could change sample rate on one audio stream without affecting the other stream. On 10.5.7 & onwards, a change in the USB audio driver publishes only 1 audio engine for both input & output streams. Changing sample rate on one stream will affect another stream (technically, the sample rate resides on the audio engine, so changing the sample rate naturally affects both streams). So in this case, changing the sample rate causes the input stream to run at a different rate that originally when Ventrilo launched. Ventrilo doesn't handle the sample rate change properly, resulting in the audio corruption (robotic/garbled, etc).

(a) This problem actually could occur on Mac OS X 10.5.6, depending on the USB audio device used. If the device can only support one sample rate, then this problem will also occur after the USB audio driver switches the sample rate on both streams when it detected one stream is falling behind.
(b) This problem is not specific to USB audio driver. Using Ventrilo for example with Firewire audio device also exhibits similar issue. The Firewire audio driver also puts input & output audio stream on the same audio engine.
--------
Jaycyn is offline   Reply With Quote