View Single Post
Old 07-02-2007, 10:49 PM   #1
Junior Member
Join Date: Jul 2007
Posts: 5
Default Ventrilo lock up w/ new usb headphones

I recently purchased the Turtle Beach AK-R8 headphones (USB). I have the latest drivers from turtle beach (Audio Advantage SRM). I have installed these same headphones on my wife's PC and used ventrilo without any problems. But on my machine I cannot get both the mic and headphones to work at the same time. My MB is an EVGA nForce 680i SLI, but keep in mind that I'm not using the on-board sound (and the turtle beach usb drivers work w/ ventrilo on my wife's PC).

When I select the 'Audio Advantage SRM device' for both inbound and outbound like I should and try to connect to a server I either get a lockup or it connects but I lose sound and mic. Even if it does connect, the headphones stop working in any other application. This only happens when I try to connect, I can change anything I want in setup.

However, if I select the on-board sound for inbound device, the mic works fine. Of course, I can't hear anyone talking back to me. Alternatively, if I select the on-board device for outbound, I can hear everyone just fine but the mic doesn't work. Same thing if I uncheck 'enable outgoing voice communications.'

I have tried every permutation of 'Use directsound' for inbound and outbound and the problem is the same. I have tried reinstalling ventrilo and the USB sound drivers. I've also tried disabling the onboard sound in the BIOS. None of these had any effect. I'm at a loss what to try at this point.

Any ideas?

sfryman is offline