View Single Post
Old 10-13-2006, 11:39 PM   #1
Pipercats
Junior Member
 
Join Date: Jul 2005
Posts: 8
Default Possible solution for Lockups in BF2

My wife and I have been plagued with innumerable lockups and freezing while using Ventrilo with BF2. We have tried all the hints and tips that have been posted in these forums as well as searching online for an answer.

Today we found a post on the creative.com forums:
http://forums.creative.com/creativel...id=2294#M48573

In playing tonight for over 3 1/2 hours .. not 1 single lockup. For those that are still fighting with it and have a soundblaster card .. give this a try.

Quote:
Well.. i finaly found out whats making my BF2 crash with my X-Fi extreme music card.
I normally run my computer with NO background programs running. But since i got my X-fi card i had a few running that comes from the install disk, that i figured i would just leave running.
CTDetect.exe
CTDVDET.exe
CTHELPER.exe
CTXFIHLP.exe

Those are all programs that run in the background when you start your computer, they are installed with the X-fi disk. When i first got my card, BF2 would crash randomly, sometimes 3 minutes into the game and sometimes an hour into the game. I tried a lot of fix's and updates, but still would crash. A while ago i downloaded and installed A.I.M. which auto starts when you start windows and i didnt like that, so i went into MSCONFIG and cleaned out ALL programs that run at startup, including the Creative ones i listed above. And later i noticed BF2 didnt crash anymore, but at the time i didnt put two and two together. Today i had to reset my BIOS and i forgot to turn off my onboard sound card, so in windows it said my sound card wasnt installed, so i thought it was my X-fi, and i go back into MSCONFIG to turn on CTDetect.exe and the rest to see if it would detect it, but i didnt realize till later it was my onboard that wasnt installed.

To make a long story shorter, I played BF2 and froze 3 different times when i had the background programs running, and now that i turned them off again, my BF2 doesnt crash. So something is wrong with the background programs. If you want to turn them off yourself follow these directions.

Click START. Click RUN. Type MSCONFIG. Press OK. Click the STARTUP tab. And DESELECT the following:
CTDetect.exe
CTDVDET.exe
CTHELPER.exe
CTXFIHLP.exe

Click Apply then OK, and restart your computer. When you restart you will get a box that tell you that you made changes. Check the checkbox, and click OK.

You will no longer crash with BF2. And you will STILL get the same preformance from your card. But your Creative Audio Console will not be running. You can still start it up by going to START, All Programs, Creative. But you might have to press CTRL ALT DELETE and end the task when you are done.
I havnt run any further tests to see EXACTLY which creative program is causing it. So for now just close ALL of them. Ill figure it out later if Creative doesnt first.

YAY no more BF2 crashes.
Pipercats is offline