Ventrilo Tech Support

Ventrilo Tech Support (
-   Windows Client (
-   -   Ventrilo lock up w/ new usb headphones (

sfryman 07-02-2007 10:49 PM

Ventrilo lock up w/ new usb headphones
I recently purchased the Turtle Beach AK-R8 headphones (USB). I have the latest drivers from turtle beach (Audio Advantage SRM). I have installed these same headphones on my wife's PC and used ventrilo without any problems. But on my machine I cannot get both the mic and headphones to work at the same time. My MB is an EVGA nForce 680i SLI, but keep in mind that I'm not using the on-board sound (and the turtle beach usb drivers work w/ ventrilo on my wife's PC).

When I select the 'Audio Advantage SRM device' for both inbound and outbound like I should and try to connect to a server I either get a lockup or it connects but I lose sound and mic. Even if it does connect, the headphones stop working in any other application. This only happens when I try to connect, I can change anything I want in setup.

However, if I select the on-board sound for inbound device, the mic works fine. Of course, I can't hear anyone talking back to me. Alternatively, if I select the on-board device for outbound, I can hear everyone just fine but the mic doesn't work. Same thing if I uncheck 'enable outgoing voice communications.'

I have tried every permutation of 'Use directsound' for inbound and outbound and the problem is the same. I have tried reinstalling ventrilo and the USB sound drivers. I've also tried disabling the onboard sound in the BIOS. None of these had any effect. I'm at a loss what to try at this point.

Any ideas?


sfryman 07-03-2007 10:59 AM

My OS is Windows XP (SP2), same as my wife's machine.

The problem happens without opening any games.

mjgraf 07-03-2007 07:06 PM

not sure.
have you tried using another USB port?
if you are using the front, try using one in the rear.

sfryman 07-20-2007 05:57 PM

It has been awhile, but I recently discovered new info.

I have tried using different usb ports, this did not make any difference.


Yesterday I unplugged my logitech G15 usb keyboard and everything worked! Don't ask why I didn't try this before...

So, it appears that the issue only occurs when both my G15 keyboard and usb headset are plugged in. I'd really rather continue to use the G15, and I've emailed tech support for both logitech (keyboad) and Turtle Beach (headset), and of course they point fingers at each other and/or ventrilo...

The G15 has a custom application for programming the keyboard, but when I uninstall this (just using the Windows built-in usb keyboard drivers) the problem persists. The G15 also has a built-in 2-port usb hub, but when I plug the headset in I get a low-power usb error.


mjgraf 07-20-2007 09:15 PM

if you have front and rear usb ports, then this should not be a problem.
have you tried this configuration?

sfryman 07-21-2007 09:01 PM


Originally Posted by mjgraf (Post 79838)
if you have front and rear usb ports, then this should not be a problem.
have you tried this configuration?

Yes, I have both front and rear USB ports.

I'm not certain what configuration you mean, but I have tried the headphones while plugged into both the front and back USB ports. I have also tried using front and back USB ports w/ the keyboard.

mjgraf 07-23-2007 10:15 AM

you have tried with the keyboard in the back and the headset in the front?

are both your keyboard and headset drivers the latest release?

TrittonRules 08-02-2007 06:25 PM

I am having the exact same problem with my headsets, and I can't give up my headsets, they are the coolest thing since sliced bread... I use the surround sound to hear people sneaking up on me.

I have a Tritton AXPC, and whenever I disconnect the G15, it starts working again. I heard it may have something to do with Asus motherboards, Sfryman, do you have asus?

TrittonRules 08-02-2007 06:49 PM

Have you tried disabling the HID components in device manager? I can't right now because I'm away from my home for a week on business. I wonder if you disable the G15 whistles and bells one at a time, if it is one of the HID Components that is causing the conflict.

SlashChicken 08-02-2007 07:10 PM

Same trouble for me with my AXPC. Never really occured to me to unplug other usb devices. I'll be giving that a try later tonight.


The headphones work after unplugging my Wacom tablet. BTW, I have an Asus mobo.

All times are GMT -5. The time now is 02:04 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.