Ventrilo Tech Support

Ventrilo Tech Support (
-   Windows Client (
-   -   Clicking Sound when engaging Push to Talk (

jestrjk 01-29-2008 06:42 PM

Clicking Sound when engaging Push to Talk

There are a couple of threads floating around here regarding a "rapid clicking" sound when pushing to talk. Id like to share my experience and final solution to this issue.

OS: Windows XP Pro - 64bit

- Pressing push to talk would be clear for a very short time after a reboot or audio driver/device change.
- Shortly after the clear period, when ever i pressed push to talk a medium volume rapid clicking or tapping sound would occur.
- Others could hear this clicking, but i could not
- Restarting Vent or orther applications would not work
- Reinstalling sound drivers would clear it for a short period < 5 min
- Rebooting cleared it for < 5 minutes
- the change came on suddenly, after 2+years of the same setup, same vent etc except for:
- I moved my machine from the floor to the top of the desk. In doing so i plugged in my USB items into different ports.

Controls used for push to talk :
- Logitech MX1000 Mouse
- Every button tested, with and without the Logitech SetPoint drivers
- Logitech G15 keyboard
- Lots of keys tested, but not all.

Audio Device Combinations: ( note: i tried EVERY combination possible of the below )

- Onboard SoundMax HD Audio ( Asus p5b plus )
- Latest and Next to latest drivers
- Sound Blaster Audigy SE
- Latets and Next to latest drivers
- 2 identical logitech desktop USB mics
- Senheiser stereo jack head phones ( no mic )
- logitech stereo jack headphone/mic set

The problem has appeared to have been solved by one of two things, or maybe a combo of both:

1. I have a USB hub in my monitor, which i did not plug back in when i moved the computer. I plugged in the USB mic into the hub, and re attached the hub to the computer.

2. I reinstalled my windows audio codecs from :

The clicking has not returned.

Hope i help someone. Thanks.

MonKENy 02-07-2008 11:46 AM

did you uncheck "play key clicks" under setup?

sorry-misread the post, thought you were asking for help lol. well this would be the first step in anycase!

masterkaj 02-14-2008 07:19 PM

What about vista? I am using Vista 64 bit and I am having the same problem. It started to happen after I installed BF2, but now I can't get it to go away, even after uninstallation.

Would like to see an answer to this, I know it's not my mic, it works fine on my friends XP setup. I have seen other posts around here, just wondering what the fix is for vista? Is it the same as the XP fix (even though that codec system requirement does not state Vista)? I haven't tried it yet because it isn't a vista codec.

My Setup:

Creative X-Fi Fatality Gamer
Logitech USB Mic
Vista Home Premium 64 bit

whytewolf 02-26-2008 12:22 AM

Same exact problem..same specs here too. Been using push to talk and others hear a clicking..squeaking sound after i'm done talking...going to have to make another thread on it.

Authorious 03-20-2008 11:03 AM

ok simple soultion to that anoying constant beeping when u push the hotkey when the game is not open:

Go to Start,
Then Control Panel,
Click the Sound, Speach and Audio Devices icon, then Sound and Audio Devices (or if u have classic view: Click on Sound and Audio Devices),
In the new window that pops up, click on the "Sounds" Tab at the top.
Then u should see in the window under Program Events a box with events such as: Asterisk, Close Program, Critical Battery Alarm etc.

Look for the one that says: Default Beep.

Click on it and then below under Sounds: change it to None (It should have been on XP Ding)


wylker 05-23-2008 03:10 AM

Ok the problem is definitely with Vista compatibility. I have the same clicking problem. I have verified that it is not my headset by recording sound on another application as well as using ventrilo on another PC. I have the same vent build on both PCs (one with XP pro and one with Vista Ultimate 64). I have tried reinstalling codecs, reinstalling audio drivers, I have tried a completely different USB headset on both PCs, again the XP machine is fine and the Vista machine has a steady clicking sound.

Here are my settings:

1) Vista Ultimate 64
2) Realtek HD Audio onboard Gigabyte P35DS3 Mobo
2a) Used both a Plantronics DSP-500 USB Headset and my backup cheapo Dynex brand USB headset.
3) All attempted applications also when not playing anything

Prog-Rocker 05-23-2008 08:56 AM

couple things to try,

set 'discard hotkey' , or different combinations of that and 'use directinput'

plug headset into mobo usb port.

unplug all un-needed usb devices just to test.

try installing the 64bit of vent.

wylker 05-23-2008 10:03 AM


Originally Posted by Prog-Rocker (Post 110353)
couple things to try,

set 'discard hotkey' , or different combinations of that and 'use directinput'

Interesting idea, but it did not help.


plug headset into mobo usb port.
It is, it is in USB0


unplug all un-needed usb devices just to test.
All that is connected is my keyboard, mouse, and headset.


try installing the 64bit of vent.
Sorry I meant to put this in my original reply. I have tried both the 64 and 32 bit clients and had identical results.

wylker 05-23-2008 12:52 PM

I found a potential fix here:

He references and links some hotfix for USB audio devices, I can't test it until later.

wylker 05-24-2008 09:35 AM


Originally Posted by wylker (Post 110367)
I found a potential fix here:

He references and links some hotfix for USB audio devices, I can't test it until later.

Update: This hotfix would not install on a fully updated Vista x64 OS. So still looking for a fix.

wylker 05-26-2008 06:37 PM

Final update from me: Installing Vista SP1 fixed this issue for me, not sure what part of it, but it works.

All times are GMT -5. The time now is 11:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.