Ventrilo Tech Support

Ventrilo Tech Support (http://forum.ventrilo.com/index.php)
-   Macintosh Client (http://forum.ventrilo.com/forumdisplay.php?f=6)
-   -   Not compatible with High Sierra? (http://forum.ventrilo.com/showthread.php?t=4386147)

craigwf 01-25-2019 03:53 AM

Not compatible with High Sierra?
 
Been using Vent for years in Windows. PC died and a friend gave me his old MacBook running OSX 10.13, however could not get Vent configured to work. I was able to connect to my favorite server, but in Settings, was unable to change press to talk key, and the one in there by default (Left Control key) doesn't work. Though I allowed Vent control of Accessibility functions when prompted, no one could hear me with or without press to talk enabled. Mic was, of course, not muted. I could hear others. I do not know which codec that server uses.

Prog-Rocker 01-25-2019 10:33 AM

what model macbook are you using?
what type of headset are you using? usb or 3/8" plug type, or built-in speaker/mic ?

which version of vent are you running? 3 or 4

in setup, is 'use push to talk' checked?
is 'enable outgoing comms' checked?

is the Input set to the name of the mic device?

when you click in the hotkey box does it initially change to 'mouse 1'

craigwf 01-28-2019 08:45 PM

what model macbook are you using? 8,1
what type of headset are you using? usb or 3/8" plug type, or built-in speaker/mic ? built-in

which version of vent are you running, 3 or 4? 4

in setup, is 'use push to talk' checked? yes
is 'enable outgoing comms' checked? yes

is the Input set to the name of the mic device? only option is default device (same with outgoing device)

when you click in the hotkey box does it initially change to 'mouse 1'? No, it says Left Control Key and cannot be changed

Prog-Rocker 01-31-2019 05:25 PM

I no longer have a macbook to test with "It's dead, Jim" but I can try to emulate with a mac-mini although it doesn't have a built-in mic.

as for the not being able to change the hotkey:

1. are you running any firewall/virus/malware apps? if yes. try temp disableing them

for the mic problem

1. goto system preferences > security > privacy tab > select microphone > make sure ventriloPro.app is checked
2. goto system preferences > sound > input > select the mic > set the input volume all the way up then speak and watch the input level meter.


do you have a usb mic you can possibly test with?

when you press the hotkey does your username turn green?

when you try to speak do other users see your icon in green or yellow? if yellow then have a sys-admin check your permissions to broadcast.

Prog-Rocker 05-07-2019 02:00 PM

The Devs have found a possible reason for the microphone not working with OSX 10.14 as noted below from Apple Developer site:

In macOS 10.14 and later, the user must explicitly grant permission for each app to access cameras and microphones. Before your app can use the capture system for the first time, macOS shows an alert asking the user to grant your app access to the microphone. macOS remembers the user’s response to this alert, so subsequent uses of the capture system don’t cause it to appear again. (The user can change permission settings for your app in System Preferences > Security & Privacy.)

This has been added in the next release of VentriloPro.


All times are GMT -5. The time now is 04:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.